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bICEPS Software User Manual

Abstract

This is the Software User Manual (SUM) for the bICEPS project. This project is a part of the course
Software Engineering (2IP40) at the Eindhoven University of Technology. The document con�rms to
the SUM guidelines of the software engineering standard, as stated by the European Space Agency
(ESA).
This document describes the functionality of the software and instructs on how to use the software
correctly.
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Chapter 1

Introduction

1.1 Intended readership

This document is intended for end users and administrators of the ICEPS system. Both roles are
formally described in [URD]. The reader is expected to have basic knowledge of the Microsoft Windows
operating system.

1.2 Applicability

This document applies to the ICEPS system, version 1.0.0.

1.3 Purpose

The purpose of this document is to assist the user in learning the ICEPS system and to serve as a
reference when using the ICEPS system.

1.4 How to use this document

First-time users are encouraged to read chapter 4 and follow each tutorial to develop a basic under-
standing of ICEPS.
More experienced users can use the reference in chapter 5 to �nd out more about speci�c features of
ICEPS.

1.5 Related documents

[URD] User Requirements Document

bICEPS
Mohammed El Kebir, Hans Wauters, Kevin Verbeek, Johan de Jong
Technische Universiteit Eindhoven, 2005 / 2006

1.6 Conventions

User Any user using the system, this is either an End-User or an Administrator
End-User The end users using the system
Administrator The administrator using the system
Italics All words in italics are texts on on-screen items

1.7 Problem reporting

Since the bICEPS team will be dissolved after completion of the ICEPS project, the issue of problem
reporting is left to Sara Lee/DE.

INTRODUCTION 1
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Chapter 2

Overview

2.1 Overview of the software

ICEPS is a system for evaluating the quality of co�ee samples by means of a certain attribute list.
The results of these evaluations can then be exported to Microsoft Excel or be viewed in a graph or
PCA-mapping.

2.2 Administrator tasks

An ICEPS administrator can create, change and delete protected attributes and protected attribute lists.
The collection of attributes and attribute lists can be exported to a �le for distribution to end-users.
The administrator can also manage the list of physical attributes on which a sample is rated.

2.3 End-User tasks

An ICEPS end-user can create, change and delete custom attributes and custom attribute lists. These
attributes and lists are only available for the end-user who created them. It is also possible to import
a �le with protected attributes and protected attribute lists, which can then be used for evaluating a
sample.
The end-user can also generate Microsoft Excel �les containing the evaluations of samples, or generate
graphs and PCA-mappings of the evaluations. For all evaluated samples, various overviews can be
generated and viewed.

2 OVERVIEW
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Chapter 3

Installation

This chapter describes how ICEPS can be installed and uninstalled on your system. Please note that
only installation is discussed in this chapter. For more information on how to import an initial set of
protected data, please see the tutorial or reference section of this document.

3.1 Installation

To begin the installation of ICEPS, double click on the executable named ICEPSsetup.exe. You should
now see the screen as shown in �gure 3.1. During the installation you can always go one step back by
clicking the Back button.

Figure 3.1: ICEPS installation screen

Click Next to proceed, and the screen show in �gure 3.2 will appear. This screen shows the location
where ICEPS will be installed (C:\ICEPS by default). If you would like to change the installation folder,
click on the Browse button and choose a new location.
When the displayed destination folder is ok, click the button Next to proceed.

Now the screen shown in �gure 3.3 will appear. Here you can choose the location for your start
menu shortcuts. Click Browse to change the destination, by default it is ICEPS.
If you don't want the installer to create a folder in your start menu, check the check box labeled Don't
create a Start Menu folder.
Now click Next to proceed to the next step.

The additional tasks screen will appear (�gure 3.4). If you want either a desktop icon or quick
launch icon, check the appropriate check box(es). Finally click Next to proceed.

You will now see the overview screen, as shown in �gure 3.5. Check if all the information is correct.
If so, click Install to start copying the ICEPS �les. If not, click Back to go back to previous steps.

When the installation completes you will see the screen shown in �gure 3.6. If you click Finish the
installer will close and ICEPS will launch.

INSTALLATION 3
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Figure 3.2: ICEPS installation destination screen

Figure 3.3: ICEPS installation shortcuts screen

Figure 3.4: ICEPS installation additional tasks screen

4 INSTALLATION
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Figure 3.5: ICEPS installation overview screen

Figure 3.6: ICEPS installation �nal screen

3.2 Uninstallation

To uninstall ICEPS, locate the shortcut Uninstall ICEPS in your ICEPS start menu folder (if you did
not create a start menu folder during installation, please use the Add/Remove Programs screen in
Windows). Click this shortcut to start the uninstall program.
Click Yes to uninstall ICEPS, if everything went right, a dialog will appear, telling ICEPS was uninstalled
succesfully.

INSTALLATION 5
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Chapter 4

Tutorials

4.1 End-User tutorials

4.1.1 Registering as a new user

Functional description

This tutorial describes how to register yourself as a new user in ICEPS.

Cautions and warnings

The password is case-sensitive.

Procedure

Before you start, please be sure to know:

• Your employee number

• A password (optional)

Start ICEPS, the screen as shown in �gure 4.1 will show up.

Figure 4.1: Login screen

Since you want to register, click on the button labeled Register new user. This will bring up the
screen as shown in �gure 4.2.

Now please enter the following things:

• For Name, enter your real name

• For Username, enter your employee number

• For Password, enter a password (this is optional)

6 TUTORIALS
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Figure 4.2: Registration screen

• If you have entered anything in the previous step, enter the same password for Con�rm Password.
If you have left Password empty, do not �ll in anything for Con�rm Password.

Finally, click on the button labeled Register. You are now registered as an end-user for ICEPS and can
login (section 4.1.2).

Likely errors

• If the values entered in Password and Con�rm Password are not the same, a messagebox will
show up, saying that the passwords do not match. You should clear the password �elds and enter
the password again.

4.1.2 Logging in as end-user

Functional description

This tutorial describes how to login as an end-user in ICEPS.

Cautions and warnings

Be sure to be a registered user in the system (see section 4.1.1).

Procedure

Before you start, please be sure to know:

• Your employee number

• Your password (if you supplied one during registration)

Start ICEPS, the screen as shown in �gure 4.1 will show.
Now enter the following information:

• For Username enter your employee number

• For Password enter the password you supplied during registration. If you did not supply a
password during registration, leave this �eld empty.

Now click on Login and the ICEPS main form will show, see �gure 4.3.

Likely errors

• If the password you supplied is not correct for the given username, a messagebox will show up,
saying that the password is incorrect. Please re-enter your password and click Login again to
retry to login.

TUTORIALS 7
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Figure 4.3: ICEPS main screen

4.1.3 Changing your password

Functional description

This tutorial describes how to change the password you use for logging in to ICEPS.

Cautions and warnings

You have to be logged in to follow this tutorial.
Remember your new password, as there is now way to retrieve it if you forget it.

Procedure

In the ICEPS mainscreen select Options -> Change Password from the menu. The change password
screen will appear, as shown in �gure 4.4.

Figure 4.4: Change password screen

In the Old password �eld, �ll in your current password (leave empty if you do not have a password
set). In the New password and Con�rm password �elds, enter your new desired password (leave empty
if you want to use no password). Make sure you type the same password in both �elds. Now click Ok

8 TUTORIALS
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to con�rm the change. When you start ICEPS the next time, you will have to login with your new
password.

Likely errors

• If you receive the error "The supplied passwords do not match", the passwords �lled in in the
New password and Con�rm password �elds are not the same. Re-enter your password and click
Ok to try again.

4.1.4 Session creation and sample evaluation

Functional description

This tutorial describes how to create a session and evaluate samples for this session.

Cautions and warnings

You have to be logged in to follow this tutorial.
The attribute lists seen in screenshots in this tutorial will probably not match the ones seen on the
user's screen.

Procedure

In the ICEPS mainscreen click on New Session in the toolbar or click on File -> New Session in the
menu. The screen shown in �gure 4.5 will show up.

Figure 4.5: New session screen

Enter the following information:

• For Session Name enter an identifying name for the session

• For Project Name enter the name of the corresponding project (optional)

• For Project Number enter the number of the corresponding project (optional)

• For Attribute List choose the attribute list you want to use for evaluating the samples in this
session

Now click on the button labeled Ok and the screen shown in �gure 4.6 will appear.

This is the session overview screen. In this screen you will see all relevant information for a session
and a list of all samples that have been evaluated in this session. We will now �rst add a description
to the session and save it.

To add a description, enter some text in the Description �eld in the session overview screen. This

TUTORIALS 9
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Figure 4.6: Session overview screen

description will be automatically saved.

Now that we have all the relevant session info �lled in, we can start a sample evaluation. Click on
the button labeled New Sample, this will bring up a message box asking for a name for the sample.
Fill in an appropriate name and click Ok. Now, the sample evaluation screen, shown in �gure 4.7, will
show up.

Figure 4.7: Sample evaluation screen

In this screen you can evaluate each attribute. All the attributes are placed on a tab for their
category.
Evaluating can be done in two ways:

• You can drag the slider next to an attribute name, the corresponding value will be displayed in

10 TUTORIALS
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the text�eld on the right

• You can directly enter a value in the text�eld on the right, the slider will accordingly move to
the corresponding position

Now evaluate every attribute on the tabs labelled Appearance, Smell, Taste and Aftertaste (one or
more of these may be absent if the attribute list does not have any attributes in these categories) and
�nally select the tab Remarks.

Now that you have evaluated all attributes you need to enter a �nal quality mark for the sample
and optionally any remarks. Enter the quality mark in the Quality Mark �eld, this can be number
ranging from 0 to 10, with two decimal places. It does not matter if you use a comma or dot as a
decimal separator, it will be auto corrected once you leave the �eld.
Enter you remarks in the Remarks �eld if you have any.

An optional last step is to add physical data for this sample, this can be done on the Physics tab
(this tab can be absent if no physics attribute list is present). Just enter the appropriate values in the
text�elds.

To �nish the evaluation, click on the button labeled Save evaluation. The session overview screen
will now contain a sample with the name you just supplied in the list of samples on the right.

If you want an overview of all samples in your session, you can click on the button labeled Sample
Overview in the session overview screen. This will bring up the screen shown in �gure 4.8.

Figure 4.8: Sample overview screen

This shows all samples with their respective scores for each attribute. In this overview you can
change the attribute evaluations by double clicking on the desired cell and entering a new value. To
save any changes made here, you have to click the Save Changes button.

TUTORIALS 11
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The overview can be printed by clicking the button labeled Print. This will bring up a standard Win-
dows print dialog.
For more information on generating graphs from the sample overview screen, see section 4.1.6.

Likely errors

• If you did not evaluate all attributes, or did not enter a quality mark, you will get a warning when
clicking Save Evaluation. This warning states that the sample will be discarded because not all
attributes are evaluated. To save the sample you need to click Cancel in this messagebox and
evaluate all atributes and give a quality mark.

4.1.5 Opening, closing, deleting and exporting sessions

Functional description

This tutorial describes how previously created sessions can be opened, closed (�nalized), deleted and
exported to Microsoft Excel �les.

Cautions and warnings

You have to be logged in to follow this tutorial.
Please be sure to have one or more open sessions with at least one evaluated sample in your system.
Also, note that when you close (�nalize) a session, it can never be opened again. Furthermore, deleted
sessions cannot be recovered. So please be careful when following this tutorial, not to close or delete
sessions on which you still want to work.

Procedure

To do any of the operations mentioned in the functional description, �rst click on the toolbar button
Open Session or click on File -> Open Session in the menu. This will bring up the open session screen,
as shown in �gure 4.9.

Figure 4.9: Session open screen

When you select a session in the list, all relevant session information will be displayed in de Session
Info box below the list.

12 TUTORIALS
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To open a session, click on the desired session in the list and then click on Open Session. This will
bring up the session overview screen which we discussed earlier.
To delete a session, click on the desired session in the list and then click on Delete Session. Now, a
messagebox will show up, asking for con�rmation. If you click Yes, the session will be deleted. Clicking
No will not delete the session.
To close a session, click on the desired session and then click on Finalize Session. Now, a messagebox
will show up, asking for con�rmation. If you click Yes, the session will be closed. Clicking No will not
close the session.

Yes, the session will be closed. Clicking No will not close the session.
To export a session and it's sample data, click on the desired session and then click on Export. You
now have the option to choose between exporting to a Microsoft Excel �le or to show the Export Log.
The �rst option will bring up a standard Windows save �le dialog. Choose a desired �lename here and
click Save to save the data to a �le. The second option option will bring up the export log screen.
The export log screen shows the export dates of the selected session.

Likely errors

None

4.1.6 Generating graphs and PCA mappings

Functional description

This tutorial describes how to generate graphs and PCA mappings from samples.

Cautions and warnings

You have to be logged in to follow this tutorial.
Please be sure to have some evaluated samples in your system. To compare samples in one graph, the
samples need to be evaluated with the same attribute list.

Procedure

Graphs can be generated in two ways:

• Based on all samples in one session, this can be done from the sample overview screen

• Based on arbitrary samples (from di�erent sessions), evaluated with the same attribute list. This
can be done from the toolbar or menu.

We will discuss both methods, starting with the �rst method.

Bring up a sample overview screen and click on the button labeled Show Graph. Now the sample
data graph screen shows up. We will discuss how this screen works further on in this section.
We will now show how to generate a graph from the toolbar/menu.
To do this, click on the toolbar button labeled Visualization and then on Graph. Or, alternatively, click
on Visualization -> Graph in the menu. This brings up the graph options screen, shown in �gure 4.10.

In the Attribute List dropdown box, you can select for which attribute list you want to compare
samples. If you select any attribute list from the dropdown box, the samples, evaluated with this
attribute list, will show up, ordered by their containing sessions.

To select the samples you want in your graph, �rst expand the sessions that contain the desired
samples. You can do this by clicking on the plus-sign in front of a session name.
You can now select the desired samples by clicking on the check boxes in front of the sample.
Another option is to select an entire session (and thus all the samples it contains), by clicking on the

TUTORIALS 13
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Figure 4.10: Graph options screen

check box in front of a session name.

When you �nished selecting samples, click on the button labeled Generate Graph to generate the
graph.
This will bring up the sample data graph screen, as shown in �gure 4.11. In this screen you can
in�uence what is displayed in the graph, print the graph and export the graph as a graphical �le.

Figure 4.11: Sample data graph screen

To display samples, select them by clicking the check box in front of the desired samples in the list
titled Show Samples. At most six samples can be displayed at a time.
The colors for each sample line can be changed by changing the values in the dropdown boxes named
Color 1, Color 2, etc. The thickness of graph lines can be changed by entering a positive value for Line
Thickness.

To print the graph, click on the button labeled Print. This brings up a standard Windows print
dialog.

14 TUTORIALS
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To export the graph to a graphical �le (.bmp or .jpg), click on the button labeled Save Picture.
This brings up a standard Windows save �le dialog. Enter the desired �lename and choose the �letype
in the dropdown box below the �lename and click on Save. Now the graph is exported to a graphical
�le and can be opened using compatible graphics software.
To generate PCA mappings, click on Visualization and then PCA Mapping in the toolbar. Or, alter-
natively, click on Visualization -> PCA Mapping in the menu. Now, the PCA mapping options screen
will show. This screen is operated the same way as the graph options screen, so we will not discuss it
here again.

After clicking on Generate PCA Mapping. The PCA mapping screen will appear, as show in �gure
4.12.

Figure 4.12: PCA mapping screen

The PCA mapping screen o�ers a lot of functionality which we will not discuss here. For more
information see section 5.1.16

Likely errors

• If you try to select more than six samples in the sample data graph screen, the seventh selected
sample will not become selected. To display the sample in the graph, deselect one or more other
samples �rst.

4.1.7 Generating closed session overviews

Functional description

This tutorial describes how to generate sample overviews of closed sessions.

Cautions and warnings

You have to be logged in to follow this tutorial.
Please make sure you have closed at least one session before starting this tutorial.

Procedure

Various overviews of sample data from closed sessions can be generated from the database operations

TUTORIALS 15
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screen.
Click on the toolbarbutton Database or click on Database -> Show Database Operations in the menu
and the database operations screen will show up. On this screen, show in �gure 4.13, the various
options for generating closed session overviews are shown.

Figure 4.13: Database operations screen

As all the descriptions on the buttons explain themselves, we will not go into detail here. After you
clicked one of the buttons (and �lled in any requested data), the closed session overview screen will
appear. This screen is shown in �gure 4.14.

Figure 4.14: Closed session overview screen

To see more information on a session, select the session or one of its samples in the listbox on the
left. The session information on the right will be updated accordingly. Samples can be made visible by
clicking the plus-sign in front of a session name.

To see more detailed information about the samples in a certain session, double click on the session
or anyone of its samples. Now the sample overview screen will appear. We already discussed this
screen in section 4.1.4, so look there for more information on how it works. The only di�erence when
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using this screen with a closed session, as opposed to an open session, is that only physical attributes
can be changed. The regular attributescores can not be changed anymore.

Likely errors

• If the closed session overview screen does not show any sessions, you probably supplied informa-
tion (project name, session name, startdate or closingdate) that does not have any related closed
sessions.

4.1.8 Importing protected data

Functional description

This tutorial describes how to import protected data that has been exported by an administrator. The
protected data is either a �le with protected attributes and protected attribute lists, or a �le with a list
of physical attributes.

Cautions and warnings

You have to be logged in to follow this tutorial.
Once you have imported �les, old attribute lists or physical attributes that were previously available
but are not in the imported data, cannot be used for new sessions.

Procedure

The steps for importing both types of data are almost the same. Therefore we will only discuss the
steps once and indicate where both procedures di�er.
To import any data �le, �rst click on the toolbar button labeled Import and then choose the desired
type of data to import. Another option is to select Options -> Import Protected Attributes Lists
or Options -> Import List Of Physical Attributes from the menu. This is the only step where both
procedures di�er, so be sure to pick the right option.

After selecting one of the previously mentioned options, a standard Windows �le open dialog will
appear. Browse for the location of the �le you want to import and select it, so it's name shows up in
the Filename �eld. Then click Ok.

The �le will now be imported into your local database. All messages generated by the import
process will be displayed in a new window. Inspect the messages to see if everything imported �ne.
You can immediately use the newly imported data for new sessions.

Likely errors

• If the �le you selected is corrupt, an errorbox will show up, telling that the �le could not be
imported. Please be sure to use a valid �le exported and distributed by an administrator.

• If the log window shows any errors, they are self explanatory.

4.1.9 Managing custom attributes

Functional description

This tutorial describes how to manage (create and delete) your custom attributes. These custom at-
tributes can later on be used to form a custom attribute list.

Cautions and warnings

You have to be logged in to follow this tutorial.
Please note that once you deleted a custom attribute, it will still be available in previously created
custom attribute lists but cannot be used anymore in newly created custom attribute lists.
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Procedure

To manage your custom attributes, click on the toolbarbutton labeled Manage Attributes or, alter-
natively, select Files -> Manage Attributes from the menu. This will bring up the manage custom
attributes screen, as shown in �gure 4.15.

Figure 4.15: Manage custom attributes screen

All custom attributes are displayed in their corresponding category. You are now able to add custom
attributes and to disable custom attributes. Disabling an attribute will make it unavailable for use in
a newly created custom attribute list. It will still be listed in previously created custom attribute lists
though.

To add a new custom attribute, click on the button labeled Add Attribute, the add new custom
attribute screen will show up, as shown in �gure 4.16.

Figure 4.16: Add new custom attribute screen

First, select the desired category for the new custom attribute in the Category dropdownlist. Now
�ll in a name for the new custom attribute in the Attribute Name �eld. Finally, click Ok to add the
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custom attribute to the list.

To disable a custom attribute, �rst, select the desired attribute. It is also possible to select more
than one attribute at a time: If the attributes you want to select are in the same category, hold ctrl
and click on the desired attributes. If the attributes are in di�erent categories you can just click them.
A combination of both is possible, too. Finally, to disable the selected custom attribute(s), click on
the button labeled Disable Attributes. Now, a messagebox will appear, asking for con�rmation. Click
on Yes to con�rm the disabling of the custom attributes, or click on No to abort the operation.

Likely errors

• While adding a new custom attribute: If you enter an attribute name in the Attribute Name
�eld that already exists in the selected category, an error message will show. Please change your
attribute name in one that is not yet in use.

4.1.10 Creating custom attribute lists

Functional description

This tutorial describes how to create a new custom attribute list. A custom attribute list can consist
of a mix of protected and custom attributes.

Cautions and warnings

You have to be logged in to follow this tutorial.

Procedure

To create a new custom attribute list, click on the toolbarbutton labeled New Attribute list or, alterna-
tively, select File -> New Attribute list from the menu. This will bring up the create custom attribute
list screen as shown in �gure 4.17.

The �rst thing to do, is �ll in a name for the new custom attribute list in the Attribute list Name
�eld. Please note that if you �ll in a name of an already existing list, this list will be overwritten.

Now you can add attributes to the list. On the left are four category-lists, this is your custom
attribute list. On the right are two tabs with four category-lists each. To add a protected attribute
to your custom attribute list, select the tab labeled Protected Attributes. Next, select one or more
attributes (multiple attributes can be selected by holding the ctrl key and clicking), and click the button
labeled Add. The selected attributes will now move to your custom attribute list. An alternative way to
add attributes is to select one or more attributes in one category and drag them to the same category
in your custom attribute list on the left.
To add a custom attribute to your custom attribute list, select the tab labeled Custom Attributes.
Next, follow the same steps as above.

To remove an attribute from your custom attribute list, select one or more attributes in the lists
on the left and click the button labeled Remove. The selected attributes will now move back to the right.

To �nish creating your custom attribute list, click on the button labeled Save List. The list will
now be saved and available for use in newly created sessions.

Likely errors

• If the name supplied in the Attribute List Name �eld already exists for another custom attribute
list, upon saving, a warning message will appear. If you click Yes, the previous version of the
attribute list with this name will be overwritten.
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Figure 4.17: Create custom attribute list screen

4.1.11 Editing and deleting custom attribute lists

Functional desciption

This tutorial describes how to edit or delete any of your custom attribute lists.

Cautions and warnings

You have to be logged in to follow this tutorial.
Please note that once you delete a custom attribute list, it will still be available in previously created
sessions (which are using that custom attribute list). Also, when you edit a custom attribute list, the
old version will still be used in previously created sessions (which are using that custom attribute list).

Procedure

To edit or delete a custom attribute list, �rst click on the toolbar button labeled Open Attribute list,
or, alternatively, select File->Open Attribute list from the menu. Now the custom attribute lists screen
will appear, as shown in �gure 4.18.
To edit a custom attribute list, select a name in the list and click the button labeled Change List.

Now the change custom attribute list screen will appear, and you can edit your list as described in 4.1.10.

To delete a custom attribute list, select a name in the list and click the button labeled Disable
List. Now a messagebox asking for con�rmation will show up. Click Yes to disable the list, or click No
to abort the operation. If you clicked Yes the custom attribute list will now disappear from the list,
otherwise, nothing happens.

Likely errors

None
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Figure 4.18: Custom attribute lists screen

4.2 Administrator tutorials

4.2.1 Logging in as administrator

Functional description

This tutorial describes how to login as an administrator.

Cautions and warnings

Please be sure to have an administrator password supplied to you.
An administrator will allways have a non-empty password.

Procedure

Start ICEPS, the screen as shown in �gure 4.19 will show.

Figure 4.19: Login screen

Now enter the following information:

• For Username enter "admin" (without the quotes).

• For Password enter the password that was supplied to you.
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Now click on Login and the ICEPS main administration form will show, see �gure 4.20.

Figure 4.20: ICEPS main administration screen

Likely errors

• If you did not �ll in "admin" in the Username �eld, you cannot login as administrator.

• If you did not supply the right password in the Password �eld, you cannot login. Please check
your password and re-enter it.

4.2.2 Managing protected attributes

Functional description

This tutorial describes how to manage (create and delete) protected attributes. These protected at-
tributes can later on be used to form attribute lists.

Cautions and warnings

You have to be logged in as administrator to follow this tutorial.
Please note that once you deleted a protected attribute, it will still be available in previously created
attribute lists but cannot be used in newly created attribute lists.

Procedure

To manage protected attributes, click on the toolbar button labeledManage Attributes or, alternatively,
select Files -> Manage Attributes from the menu. This will bring up the manage protected attributes
screen, as shown in �gure 4.21.
All protected attributes are displayed in their corresponding category. You are now able to add

protected attributes and to delete protected attributes. Deleting an attribute will make it unavailable
for use in a newly created attribute lists. It will still be listed in previously created attribute lists though.
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Figure 4.21: Manage protected attributes screen

To add a new protected attribute, click on the button labeled Add Attribute, the add new protected
attribute screen will show up, as shown in �gure 4.22.

Figure 4.22: Add new protected attribute screen

First, select the desired category for the new protected attribute in the Category dropdownlist.
Now �ll in a name for the new protected attribute in the Attribute Name �eld. Finally, click Ok to
add the protected attribute to the list.

To delete a protected attribute, �rst, select the desired attribute. It is also possible to select more
than one attribute at a time: If the attributes you want to select are in the same category, hold ctrl
and click on the desired attributes. If the attributes are in di�erent categories you can just click them.
A combination of both is possible, too. Finally, to delete the selected protected attribute(s), click on
the button labeled Delete Attributes. Now, a messagebox will appear, asking for con�rmation. Click
on Yes to con�rm the deletion of the protected attributes, or click on No to abort the operation.

Likely errors
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• While adding a new protected attribute: If you enter an attribute name in the Attribute Name
�eld that already exists in the selected category, an error message will show. Please change your
attribute name into one that is not yet in use.

4.2.3 Creating protected attribute lists

Functional description

This tutorial describes how to create a new protected attribute list. A protected attribute list contains
only protected attributes.

Cautions and warnings

You have to be logged in as administrator to follow this tutorial.

Procedure

To create a new protected attribute list, click on the toolbarbutton labeled New Attribute list or,
alternatively, select File -> New Attribute list from the menu. This will bring up the create protected
attribute list screen as shown in �gure 4.23.

Figure 4.23: Create protected attribute list screen

The �rst thing to do, is �ll in a name for the new protected attribute list in the Attribute list Name
�eld. Please note that if you �ll in a name of an already existing list, this list will be overwritten.

Now you can add attributes to the list. On the left are four category-lists, this is your protected
attribute list. On the right are also four category-lists. To add a protected attribute to your protected
attribute list, select one or more attributes on the right (multiple attributes can be selected by holding
the ctrl key and clicking), and click the button labeled Add. The selected attributes will now move to
your protected attribute list. An alternative way to add attributes is to select one or more attributes
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in one category and drag them to the same category in your protected attribute list on the left.

To remove an attribute from your protected attribute list, select one or more attributes in the lists
on the left and click the button labeled Remove. The selected attributes will now move back to the right.

To �nish creating your protected attribute list, click on the button labeled Save List. The list will
now be saved and can be exported (see section 4.2.6).

Likely errors

• If the name supplied in the Attribute list Name �eld already exists for another protected attribute
list, upon saving, a warning message will appear. If you click Ok, the previous version of the
attribute list with this name will be overwritten.

4.2.4 Editing and deleting protected attribute lists

Functional desciption

This tutorial describes how to edit or delete any of the protected attribute lists.

Cautions and warnings

You have to be logged in as administrator to follow this tutorial.

Procedure

To edit or delete a protected attribute list, �rst click on the toolbar button labeled Open Attribute
list, or, alternatively, select File->Open Attribute list from the menu. Now the protected attribute lists
screen will appear, as shown in �gure 4.24.

Figure 4.24: Protected attribute lists screen

To edit a protected attribute list, select a name in the list and click the button labeled Change List.
Now the change protected attribute list screen will appear, and you can edit your list as described in
4.2.3.

To delete a protected attribute list, select a name in the list and click the button labeled Delete
List. Now a messagebox asking for con�rmation will show up. Click Yes to delete the list, or click No
to abort the operation. If you clicked Yes the protected attribute list will now disappear from the list,
otherwise, nothing happens.
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Likely errors

None

4.2.5 Managing the list of physical attributes

Functional description

This tutorial describes how to manage the list of physics attributes.

Cautions and warnings

You have to be logged in as administrator to follow this tutorial.
Please note that once you delete a physics attribute from the list, it is not possible to recover it.

Procedure

To open the current list of physical attributes, click on the toolbarbutton labeled Manage Physics
Attribute list. Now the manage physics attribute list screen will appeaar, as shown in �gure 4.25.

Figure 4.25: Manage physics attribute screen

To add a new physics attribute to the list, click on the button labeled Add Attribute. This will
bring up the add new physics attribute screen, shown in �gure 4.26.

Now �ll in a name for the new attribute in the Attribute Name �eld. To add the attribute to the
list, click the button labeled Ok. To abort the operation, click Cancel.

To delete a physics attribute, select an attribute in the manage physics attribute screen. To delete
the selected attribute, click the button labeled Delete Attribute. A messagebox will now ask for con�r-
mation. To really delete the attribute, click the button labeled Yes in this messagebox. To abort the
operation, click No. If you clicked Yes, the attribute will disappear from the list.

Likely errors
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Figure 4.26: Add new physics attribute screen

• While adding a new physics attribute: If you enter an attribute name in the Attribute Name �eld
that already exists in the physics attribute list, an error message will show. Please change your
attribute name into one that is not yet in use.

4.2.6 Exporting protected data

Functional description

This tutorial describes how to export protected attributes and protected attribute lists, as well as the
physics attribute list to a �le. This �le can then be imported by an ICEPS end-user.

Cautions and warnings

You have to be logged in as administrator to follow this tutorial.

Procedure

The steps for exporting both types of data are almost the same. Therefore we will only discuss the
steps once and indicate where both procedures di�er.
To export any data to a �le, �rst click on the toolbar button labeled Export and then choose the

desired type of data to export. Another option is to select Options -> Export Protected Attributes
Lists or Options -> Export List Of Physical Attributes from the menu. This is the only step where
both procedures di�er, so be sure to pick the right option.

After selecting one of the previously mentioned options, a standard Windows �le save dialog will
appear. Browse for the location where you want to save the �le and enter the desired �lename in the
Filename textbox. Then click Ok.

The protected data will now be exported to an ICEPS readable �le. These �les can then be dis-
tributed to end-users, who can import them.

Likely errors

None
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Chapter 5

References

This chapter is divided into two sections, one for end-users and one for administrators. Login and
registration procedures are only described in the end-user reference.

5.1 End-user reference

This section serves as a reference for end-users of the ICEPS system. Every screen in the system is
documented here, along with all possible operations in the screen, examples of usage, possible errors
and references to related screens.

5.1.1 Login screen

Functional description

This screen is the �rst screen that shows up when you start ICEPS. It is used to enter the user's
username and password so the user can login to the ICEPS system. Also, there is a registration button
for new users.

Figure 5.1: Login screen

Cautions and warnings

None

Operations
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Operation Steps Result

Set login
username

- Enter the username in the Username
�eld

Upon the "Login" operation, the en-
tered username will be used as user-
name.

Set login
password

- Enter the password in the Password �eld Upon the "Login" operation, the en-
tered password will be used as pass-
word.

Login - Set the username and password (possi-
bly empty)
- Click Login

The login screen will close and the
ICEPS main screen will appear, you
are logged in.

Close ICEPS - Click Cancel ICEPS will close.
Open reg-
istration
screen

- Click Register new user The registration screen will appear,
see section 5.1.2.

Possible errors
Error message Cause

Please �ll in a username You did not supply a username in the Username �eld.
Username or password incorrect The supplied username is not registered, or your password

is incorrect.

Related screens
Reference topic Section

Registration screen 5.1.2
ICEPS main screen 5.1.3

5.1.2 Registration screen

Functional description

This screen o�ers the functionality for registering a new user in the ICEPS system on your local com-
puter.

Figure 5.2: Registration screen

Cautions and warnings

Once you registered on a computer, you are only registered on that very computer. If you want to
work in ICEPS again on another computer, you will have to register again.

Operations
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Operation Steps Result

Set name - Enter your real name in the Name �eld Upon the "Register" operation, the
entered name will be used as name.

Set username - Enter your employee number in the
Username �eld

Upon the "Register" operation, the
entered employee number will be used
as username.

Set password - Enter your desired password in the Pass-
word �eld. if you do not want to use a
password, leave this �eld empty.
- Enter the password you entered in the
previous step again in the Con�rm Pass-
word �eld. If you did not enter a pass-
word in the previous step, leave this �eld
empty.

Upon the "Register" operation, the
entered password will be used as pass-
word.

Register - Set all �elds in the screen
- Click Register

The login screen will appear, and you
can now login with the username and
password you just supplied.

Cancel regis-
tration

- Click Cancel The login screen will appear, you did
not register as a new user.

Possible errors
Error message Cause

Please �ll in your name You did not supply your real name in the Name �eld
Please �ll in a username You did not supply your employee number in the Username

�eld
The supplied passwords do not match The passwords in the Password and Con�rm Password

�elds are not the same

Related screens
Reference topic Section

Login screen 5.1.1

5.1.3 ICEPS main screen

Functional description

This is the main screen of the ICEPS system. It mainly serves two purposes: �rstly, to display all active
screens the user has opened. Secondly, to act as an interface from which the user can open various
screens that provide the main functionality of ICEPS.
The top of the screen consists of a menu bar (displaying �le, visualization, database etc.) and a tool-
bar with graphical buttons. All relevant screens can be opened from the menu. The toolbar acts as a
shortcut for the menu and contains buttons for most screens in ICEPS.
The center of the screen is called the "workspace" and will contain all open screens.
The bottom of the screen consists of a statusbar that will display short help messages for every toolbar
button.

Cautions and warnings

All screens that open up within the ICEPS main screen can be closed without closing ICEPS. If you
close the ICEPS main screen, however, ICEPS will be closed too.

Operations
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Figure 5.3: ICEPS main screen

Operation Steps Result

Open the new
session screen

- Click on the toolbarbutton labeled New
Session or select File->New Session from
the menu

The create new session screen will ap-
pear (section 5.1.7).

Open the
open session
screen

- Click on the toolbarbutton labeled Open
Session or select File->Open Session
from the menu

The open session screen will appear
(section 5.1.5).

Open the
new custom
attribute list
screen

- Click on the toolbarbutton labeled New
Attribute list or select File->New At-
tribute list from the menu

The custom attribute list screen will
appear (section 5.1.11).

Open the
open custom
attribute list
screen

- Click on the toolbarbutton labeled Open
Attribute list or select File->Open At-
tribute list from the menu

The open custom attribute list screen
will appear (section 5.1.12).

Open the
manage
custom
attributes
screen

- Click on the toolbarbutton labeledMan-
age Attributes or select File->Manage
Attributes from the menu

The manage custom attributes screen
will appear (section 5.1.13).

Open the
PCA map-
ping options
screen

- Click on the toolbarbutton labeled Vi-
sualization and click on PCA Mapping or
select Visualization->PCA Mapping from
the menu

The pca mapping options screen will
appear (section 5.1.15).

Open the
graph options
screen

- Click on the toolbarbutton labeled Vi-
sualization and click on Graph or select
Visualization->Graph from the menu

The graph options screen will appear
(section 5.1.17).

Open the
database
operations
screen

- Click on the toolbarbutton labeled
Database or select Database->Show
Database Operations from the menu

The database operations screen will
appear (section 5.1.19).
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Import
protected at-
tributes and
protected
attribute lists

- Click on the toolbarbutton labeled Im-
port and click on Attributes & Lists
or select Options->Import Protected At-
tributes & Lists from the menu
- Now a standard Windows open �le di-
alog will appear. Browse for the �le you
want to import and click on it, then click
Open

The �le with protected attributes and
protected attribute lists will be im-
ported. The contents of the �les (at-
tributes and attribute lists) can now
be used for new sessions.

Import phys-
ical attribute
list

- Click on the toolbarbutton labeled Im-
port and click on Physics or select Op-
tions->Import List Of Physical Attributes
from the menu
- Now a standard Windows open �le di-
alog will appear. Browse for the �le you
want to import and click on it, then click
Open

The �le with a list of physical at-
tributes will be imported. This list will
now be used for all samples created in
the future.

Open the log
�le

- Select Options->Show Log from the
menu

The show log screen will appear (sec-
tion 5.1.6)

Open the
help interface

- Click on the toolbarbutton labeled Help
or select Help->ICEPS Help from the
menu

The help interface will appear.

Open the
change pass-
word screen

- Select Options->Change Password
from the menu

The change password screen will ap-
pear (section 5.1.4).

Tile open
screens

- Select Window ->Tile from the menu All open screens will be tiled.

Cascade open
screens

- Select Window ->Cascade from the
menu

The open screens will be cascaded.

Close all open
screens

- Select Window ->Close All from the
menu

All open windows will be closed.

Bring a cer-
tain screen
to the fore-
ground

- Select Window from the menu
- Now click on the name of the screen you
want on the foreground

The selected screen is brought to the
foreground.

Possible errors

None

Related screens
Reference topic Section

Change password screen 5.1.4
Open session screen 5.1.5
Show log screen 5.1.6
Create new session screen 5.1.7
Custom attribute list screen 5.1.11
Open custom attribute list screen 5.1.12
Manage custom attributes screen 5.1.13
PCA mapping options screen 5.1.15
Graph options screen 5.1.17
Database operations screen 5.1.19
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5.1.4 Change password screen

Functional description

This screen o�ers the possibility to change the password you use to login.

Figure 5.4: Change password screen

Cautions and warnings

There is no way to retrieve your password if you forget it, so please make sure you remember your new
password.

Operations
Operation Steps Result

Set current
password

- Enter your current password in the Old
Password �eld

Upon the "Change password" oper-
ation, the entered password will be
checked against your current pass-
word, both should be the same.

Set new pass-
word

- Enter your desired new password in the
New Password �eld. Leave this empty
if you do not want to use a password to
login.
- Enter the password entered in the previ-
ous step, again in the Con�rm Password
�eld. If you left the New Password �eld
empty, leave this �eld empty too.

Upon the "Change password" oper-
ation, the entered passwords will be
used as the new password.

Change pass-
word

- Set all �elds in this screen
- Click Ok

The change password screen will close
and your password has now changed
into the value you entered in New
Password.

Cancel pass-
word change

- Click Cancel The change password screen will close
and your password has not been
changed.

Possible errors
Error message Cause

The old password is incorrect The password supplied in Old Password is not correct.
The supplied passwords do not match The values entered in the New Password and Con�rm Pass-

word �elds are not the same.

Re-

lated screens

None
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5.1.5 Open session screen

Functional description

This screen o�ers the functionality to open, delete, close or export an existing session. The top half
of the screen displays a list of existing open sessions. The bottom half displays information for the
selected session.
All exports are logged, this log can also be brought up from this screen.

Figure 5.5: Open session screen

Cautions and warnings

Once you delete a session, it cannot be recovered anymore.
Closed sessions cannot be opened again.

Operations
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Operation Steps Result

Display
session infor-
mation

- Select a session from the list All available session information will
be displayed in the lower half of the
screen.

Open session - Select a session from the list
- Click Open Session

The open session screen will close and
the session screen (section 5.1.8) will
appear, showing the session you just
selected.

Delete ses-
sion

- Select a session from the list
- Click Delete Session

A messagebox asking for con�rmation
will appear. Upon con�rmation the
session will be deleted and removed
from the session list.

Close session - Select a session from the list
- Click Finalize Session

A messagebox asking for con�rmation
will appear. Upon con�rmation

Export ses-
sion to Excel
�le

- Select a session from the list
- Click Export and select Export to Excel
- A standard Windows save �le dialog will
appear. Browse for the location where
you want to save the �le.
- Enter the desired �lename in the File-
name �eld
- Click Save

The session (and samples it contains)
will be exported to a Microsoft Excel
�le.

Show export
log

- Click Export and select Show Export
Log

Possible errors

None

Related screens
Reference topic Section

Session screen 5.1.8

5.1.6 Show Log screen

Functional description

This screen o�ers the possibility to view and clear the log �le.

Figure 5.6: Show Log screen

Cautions and warnings

None
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Operations
Operation Steps Result

Clear log - Click Clear Log Upon the "Clear Log" operation, the
log �le will be cleared.

Possible errors

None

Related screens

None

5.1.7 Create new session screen

Functional description

This screen o�ers the functionality to create a new session. It asks for some basic information and
creates a session using this information.

Figure 5.7: Create new session screen

Cautions and warnings

The information �lled in in this screen cannot be changed after pressing Ok.

Operations
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Operation Steps Result

Set new ses-
sion name

- Enter a name for the session in the Ses-
sion Name �eld

Upon the "Create new session" oper-
ation, the entered name will be used
as name for the session.

Set project
name

- (Optional) Enter the name of the project
this session belongs to in the Project
Name �eld

Upon the "Create new session" opera-
tion, the entered project name will be
saved with the session.

Set project
number

- (Optional) Enter the number of the
project this session belongs to in the
Project Number �eld

Upon the "Create new session" oper-
ation, the entered project number will
be saved with the session.

Set attribute
list

- Choose an attribute list from the At-
tribute list dropdownlist

Upon the "Create new session" oper-
ation, the chosen attribute list will be
used for the session.

Create new
session

- Set the session name and attribute list
(project name and number are optional)
- Click Ok

The new session screen will close and
the session screen (section 5.1.8) will
appear, containing your newly created
session.

Cancel cre-
ation

- Click Cancel The new session screen will close and
the create new session screen will close
and no new session is created.

Possible errors
Error message Cause

Please enter a session name You did not enter a session name in the Session Name �eld.
Please choose an attribute list You did not choose an attribute list in the Attribute list

dropdownlist.

Related screens
Reference topic Section

Session screen 5.1.8

5.1.8 Session screen

Functional description

This screen o�ers an overview of all information for a session and all samples for this session. It also
serves as a starting point for starting new sample evaluations and manipulating the samples in the
session.

Figure 5.8: Session screen
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Cautions and warnings

Once you delete a sample, there is no way to recover it.

Operations
Operation Steps Result

Change ses-
sion descrip-
tion

- Enter the desired description in the De-
scription textbox

The description will be automatically
saved

Start new
sample evalu-
ation

- Click New Sample
- Enter a new for the sample

The sample evaluation screen (section
5.1.9) will appear.

Delete sam-
ple

- Select the sample you want to delete in
the list on the right
- Click Delete Sample

A messagebox asking for con�rmation
will appear. Upon con�rmation the
sample will be deleted and removed
from the list of samples.

Copy sample - Select the sample you want to copy from
the list on the right
- Click Copy Sample
- Enter a name for the copy
- Click Ok

The selected sample is copied and
added to the list under the name you
gave in step three.

Open sample
for evaluation

- Select the sample you want to open from
the list on the right
- Click Open Sample or double click on
the sample in the list

The sample evaluation screen (section
5.1.9) will appear, showing the evalu-
ation for the selected sample.

Show sample
overview

- Click Sample Overview The sample overview screen (sec-
tion 5.1.10) will appear, showing an
overview of the samples for this ses-
sion.

Possible errors
Error message Cause

A sample with this name already exist The name you entered upon creating or copying a sample
already exists in this session.

Related screens
Reference topic Section

Sample evaluation screen 5.1.9
Sample overview screen 5.1.10

5.1.9 Sample evaluation screen

Functional description

This screen contains all necessary functions to evaluate a sample. Furthermore the quality mark, re-
marks and physical attributes of a sample can be entered in this screen.
The screen consists of a maximum of 6 tabs and 3 buttons. The four leftmost tabs are used for
assigning scores to each attribute. The �fth tab is used for the quality mark and remarks, while the
sixth tab is used for assigning values to the list of physical attributes.
The buttons are used to control the course of the evaluation, they can be used to save and cancel the
evaluation and to mark a sample as "bad".

Cautions and warnings

We assume the chosen attribute list has attributes for all tabs. If a tab has no attributes, it will not
be visible.
When canceling an evaluation, all entered information will be discarded, there is no way to retrieve this
information once an evaluation is canceled by the user.
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Figure 5.9: Sample evaluation screen

Operations
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Operation Steps Result

Evaluate an
attribute

- Select one of the four leftmost tabs
- Drag the slider next to an attribute
name to the desired position, the textbox
on the right will display the current value
- (Alternative to previous step) Enter
a number in the range [0..100] in the
textbox on the right, the slider will au-
tomatically move to this position
- Select any other control in the screen

The evaluation for this attribute is
saved.

Enter quality
mark

- Select the tab labeled Remarks
- Enter a value in the range [0..10] in the
Quality Mark �eld. You can use a preci-
sion of 1 hundredth, use a comma or dot
as decimal separator
- Select any other control in the screen

The quality mark is saved.

Enter remark - Select the tab labeled Remarks
- Enter a remark in the Remarks textbox
- Select any other control in the screen

The remark is saved.

Enter physi-
cal attribute

- Select the tab labeled Physics
- Enter a value in the textbox next to the
name of a physical attribute
- Select any other control in the screen

The value for the physical attribute is
saved.

Mark sample
as "bad"

- Click Bad Sample All attributes that were not evaluated
yet will be given a score of 0, the sam-
ple will receive a quality mark of 0.0
and the Remarks textbox will contain
the text "� Bad Sample �". The tab
labeled Remarks will be selected.

Save evalua-
tion

- Click Save Evaluation The sample evaluation screen will
close and the sample evaluation is
saved.

Cancel evalu-
ation

- Click Cancel Evaluation or close the
sample evaluation screen by clicking the
cross in the right upper corner
- Click Yes in the messagebox

The sample evaluation screen will
close and the sample and its evalu-
ation is discarded.

Possible errors
Error message Cause

Please enter a number between 0 and
10

You entered a value outside the range [0..10] or a non-
number in the Quality Mark �eld.

Related screens

None

5.1.10 Sample overview screen

Functional description

This screen contains an overview of all samples in a session. The session information box at the top
contains a summary of the available information for the session. The table on the bottom part of the
screen contains an overview of all samples (each sample has its own column) and for each sample their
scores for each attribute, the quality mark and scores for physical attributes.
It is possible to change the displayed attribute values in this screen.
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Furthermore a graph of all the sample can be generated and the overview can be printed.

Figure 5.10: Sample overview screen

Cautions and warnings

If this screen was opened from the closed sessions overview screen (section 5.1.20), only the physical
attribute scores can be changed.
Operations
Operation Steps Result

Print sample
overview

- Click Print
- A standard Windows print dialog will ap-
pear, select the desired options and click
Print

The sample overview will be printed.

Show graph
for all sam-
ples

- Click Show Graph The graph screen (section 5.1.18) will
appear, containing the samples shown
in the sample overview screen.

Change at-
tributescore
(normal or
physical)

- Double click on a value in a row with an
attributename
- Enter a value in the range [0..100]
- Select any other �eld in the table

The new value is saved.

Possible errors
Error message Cause

This is not a valid score You entered a value outside of the range [0..100] in an
attribute value �eld.

This is not a valid quality mark You entered a value outside of the range [0..10] in a quality
mark �eld.

Related screens
Reference topic Section

Graph screen 5.1.18
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5.1.11 Custom attribute list screen

Functional description

This screen contains all functionality to compose a custom attribute list out of protected and custom
attributes. The screen is used for both creating new custom attribute lists as well as for changing
existing lists. It also contains a button to quickly add a new custom attribute.

Figure 5.11: Custom attribute list screen

Cautions and warnings

If you are changing an existing attribute list, upon saving, the old list version will be overwritten. From
that point on it is no longer possible to use the old version of the list in newly created sessions.

Operations
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Operation Steps Result

Set attribute
list name

- Enter the desired name in the Attribute
list Name �eld

Upon saving this list, the entered
value will be used as identifying name
for the list.

Add pro-
tected at-
tribute(s)
to custom
attribute list

- Select the tab labeled Protected At-
tributes
Alternative 1
- Select one or more (by holding ctrl and
clicking) attributes you want to add to
the list (you can pick multiple attributes
in multiple categories)
- Click Add
Alternative 2
- Select one or more (by holding ctrl and
clicking) attributes you want to add to
the list (all attributes must be in the same
category)
- Click and hold the left mouse button,
now drag to the same category on the
left side of the screen
- Release the left mouse button when in-
side the category list on the left

The selected attributes will have
moved from the lists on the right to
the lists on the left. Upon saving this
custom attribute list, all attributes in
the lists on the left will be in the cus-
tom attribute list.

Add custom
attribute(s)
to custom
attribute list

- See "Add protected attribute to list",
make sure you select the tab labeled Cus-
tom Attributes instead of Protected At-
tributes

The selected attributes will have
moved from the lists on the right to
the lists on the left. Upon saving this
custom attribute list, all attributes in
the lists on the left will be in the cus-
tom attribute list.

Remove at-
tribute(s)
from custom
attribute list

- Select one or more (by holding ctrl and
clicking) attributes in the categories on
the left
- Click Remove

The selected attributes will have
moved from the lists on the left to the
lists on the right. Upon saving this
custom attribute list, all attributes in
the lists on the left will be in the cus-
tom attribute list.

Open add
new custom
attribute
screen

- Select the tab labeled Custom At-
tributes
- Click Add New Custom Attribute

The add new custom attribute screen
(section 5.1.14) will appear.

Save custom
attribute list

- Click Save List The custom attribute list screen closes
and the custom attribute list is saved.
The attribute list can now be used in
newly created sessions.

Cancel
changes/
creation

- Click Cancel or close the screen by click-
ing the cross in the right upper corner

A messagebox will ask for con�rma-
tion. Upon con�rmation the custom
attribute list screen will close and all
changes will be discarded, if you were
in the process of creating a new at-
tribute list, no list is created.

Possible errors
Error message Cause

Please enter a name for the list You did not enter a name for the attribute list in the At-
tribute list Name �eld.

List cannot be empty You did not add any attributes to the attribute list.
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Related screens
Reference topic Section

Add new custom attribute screen 5.1.14

5.1.12 Open custom attribute list screen

Functional description

This screen contains the functionality to open or disable a custom attribute list. It consists of a list
of available custom attribute lists and two buttons to open or disable a list.
Disabling a list will make it unavailable for future use in new sessions, but keep it available for earlier
created sessions.

Figure 5.12: Open custom attribute list screen

Cautions and warnings

Once you disable a custom attribute list, there is no way to recover it.

Operations
Operation Steps Result

Open custom
attribute list

- Select the desired custom attribute list
in the listbox
- Click Change List

The custom attribute list screen (sec-
tion 5.1.11 will appear.

Disable cus-
tom attribute
list

- Select the desired custom attribute list
in the listbox
- Click Disable List

A messagebox asking for con�rmation
will appear. Upon con�rmation the
selected attribute list will be disabled
for future use.

Possible errors

None

Related screens
Reference topic Section

Custom attribute list screen 5.1.11

5.1.13 Manage custom attributes screen

Functional description
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This screen contains all the functionality to maintain your custom attributes. These custom at-
tributes can be used to form custom attribute lists.
Custom attributes can be added or disabled in this screen. Disabling an attribute will make it unavail-
able for use in newly created attribute lists. It will, however, stay available for existing custom attribute
lists.

Figure 5.13: Manage custom attributes screen

Cautions and warnings

Once you disable a custom attribute, there is no way to recover it.
A disabled attribute that is still in a custom attribute list, and then is removed from that attribute list,
cannot be added again because it is disabled.

Operations
Operation Steps Result

Open add
new custom
attribute
screen

- Click Add Attribute The add new custom attribute screen
(section 5.1.14) will appear.

Disable
attribute

- Select one or more (by holding ctrl an
clicking) attributes you wish to disable
- Click Disable Attribute(s)

A message box will appear, asking for
con�rmation. Upon con�rmation, the
selected attributes will be disabled for
future use and removed from the cat-
egory lists.

Possible errors

None
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Related screens
Reference topic Section

Add new custom attribute screen 5.1.14

5.1.14 Add new custom attribute screen

Functional description

This screen o�ers the functionality to give a name and category for a new custom attribute. This
screen can only be brought up from the manage custom attributes screen (5.1.13).

Figure 5.14: Add new custom attribute screen

Cautions and warnings

None

Operations
Operation Steps Result

Set attribute
category

- Select the desired category from the
Category dropdownlist

Upon the "Add attribute" operation,
the selected category will be used as
category for the new attribute.

Set attribute
name

- Enter the desired name in the Attribute
Name �eld

Upon the "Add attribute" operation,
the entered name will be used as the
name for the new attribute.

Add attribute - Set the Category and Attribute Name
�elds
- Click Ok

The add new custom attribute screen
will close and the new attribute is
added to the list of its category.

Possible errors
Error message Cause

There already exists an attribute with
the same name

You entered an attribute name in the Attribute Name �eld
that already exists in the category selected in the Category
dropdownlist.

Related screens
Reference topic Section

Manage custom attributes screen 5.1.13

5.1.15 PCA mapping options screen

Functional description

This screen o�ers the functionality to set the options for a PCA mapping which can then be generated.
The list on the left displays a treeview of sessions and samples. The panel on the right shows session
and sample information for the selected session/sample.
Cautions and warnings

None
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Figure 5.15: PCA mapping options screen

Operations
Operation Steps Result

Select at-
tribute list

- Select the desired attribute list from the
Attribute List dropdown list.

The list on the left will display all open
and �nalized sessions, using the se-
lected attribute list.

Select sam-
ples for PCA
mapping

- Click on a checkbox in front of a session
or sample in the list on the left

Clicking on a checkbox in front of a
session will select all its samples. All
checked samples will be included in
the PCA mapping.

Display
session infor-
mation

- Click on a session in the list on the left The panel on the right will show all
relevant session information.

Display
sample de-
scription

- Click on a sample in the list on the left The panel on the right will show the
sample's session information as well as
the sample description.

Generate
PCA map-
ping

- Click on the button labeled Generate
PCA Mapping

The PCA mapping screen (section
5.1.16) will appear. Containing a PCA
mapping of all selected samples.

Possible errors
Error message Cause

Please select at least 2 samples You did not select at least 2 samples in the list on the left
of the screen.

Related screens
Reference topic Section

PCA mapping screen 5.1.16

5.1.16 PCA mapping screen

Functional description

This screen shows a PCA mapping and o�ers various controls for in�uencing the way the mapping is
displayed.
Cautions and warnings

None
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Figure 5.16: PCA mapping options screen

Operations
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Operation Steps Result

Pan mapping - Click and hold the right mouse button
in the mapping

Dragging the mouse in any direction
will pan the mapping in that direction.

Hide/unhide
displayed
sample labels

- Click on the check box in front of a
sample name

The selected sample will disappear
from the PCA mapping.

Change map-
ping title

- Edit the value in the Title �eld The value in the Title �eld will appear
above the PCA mapping.

Change map-
ping subtitle

- Edit the value in the Subtitle �eld The value in the Subtitle �eld will ap-
pear below the title, above the PCA
mapping.

Invert x-axis - Click on the checkbox in front of the
label Invert X-Axis

The attribute scores are inverted along
the x-axis.

Invert y-axis - Click on the checkbox in front of the
label Invert Y-Axis

The attribute scores are inverted along
the y-axis.

Swap x- and
y-axis

- Click on the checkbox in front of the
label Swap axes

The x- and y-axis are swapped.

Standardize
attribute
data

- Click on the checkbox in front of the
label Standardize data

All attribute data is standardized.

Enter zoom
mode

- Click on the magnifying glass button Zoom mode is enabled. The magnify-
ing glass button is pressed down.

Zoom in/out
in zoom
mode

- Click and hold the left mouse button in
the mapping

When moving the mouse to the left,
you zoom in. Moving the mouse to
the right will zoom out.

Exit zoom
mode

- Click on the pressed down magnifying
glass button

Zoom mode is disabled. The magnify-
ing glass button is not pressed down.

Enter zoom
x-axis mode

- Click on the x button Zoom x-axis mode is enabled. The x
button is pressed down.

Zoom in/out
in zoom x-
axis mode

- Click and hold the left mouse button in
the mapping

When moving the mouse to the left,
you zoom in along the x-axis. Moving
the mouse to the right will zoom out
along the x-axis.

Exit zoom x-
axis mode

- Click on the pressed x button Zoom x-axis mode is disabled. The x
button is not pressed down.

Enter zoom
y-axis mode

- Click on the y button Zoom y-axis mode is enabled. The y
button is pressed down.
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Zoom in/out
in zoom y-
axis mode

- Click and hold the left mouse button in
the mapping

When moving the mouse to the left,
you zoom in along the y-axis. Moving
the mouse to the right will zoom out
along the y-axis.

Exit zoom y-
axis mode

- Click on the pressed y button Zoom y-axis mode is disabled. The y
button is not pressed down.

Enter at-
tribute scale
mode

- Click on the Att button Attribute scale mode is enabled. The
Att button is pressed down.

Scale in at-
tribute scale
mode

- Click and hold the left mouse button in
the mapping

When moving the mouse to the left,
you scale all values up. Moving the
mouse to the right will scale all values
down.

Exit attribute
scale mode

- Click on the pressed Att button Attribute scale mode is disabled. The
Att button is not pressed down.

Recalculate
mapping

- Click on the button labeled Recalculate The mapping will be recalculated us-
ing only the selected samples in the
listbox in the top-left of the screen.

Print map-
ping

- Click on the button labeled Print A standard Windows print dialog will
appear. Here you can edit the printer
settings and print the mapping.

Save map-
ping to
graphical �le

- Click on the button labeled Save Picture A standard Windows �le save dialog
will appeaar. Here you can choose a
location and �lename for your picture
and select the format to save in.

Possible errors
Error message Cause

Not enough data to produce PCA
mapping

You did not select at least 2 samples in the list in the
top-left of the screen.

Related screens

None

5.1.17 Graph options screen

Functional description

This screen o�ers the functionality to set the options for a sample data graph which can then be
generated. The list on the left displays a treeview of sessions and samples. The panel on the right
shows session and sample information for the selected session/sample.

Cautions and warnings

None

Operations
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Figure 5.17: Graph options screen

Operation Steps Result

Show ses-
sion's sam-
ples

- Click the plus-sign in front of the desired
session

The tree will expand and show the
names of the samples for this session.

Hide session's
samples

- Click on the minus-sign in front of the
desired session

The tree will collapse and hide the
names of the samples for this session.

Generate
graph

- Click on the checkbox of the sessions
you would like to see a graph for, or, if it
is expanded, click on one of its samples
checkboxes
- Click Generate Graph

The graph screen (section 5.1.18 will
appear.

Possible errors
Error message Cause

Please select at least 1 sample None of the samples in the list on the left were selected.

Related screens
Reference topic Section

Graph screen 5.1.18

5.1.18 Graph screen

Functional description

This screen shows the graph based on the samples selected on the left of the screen. It also enables
you to edit the graph and to print or save it.

Cautions and warnings

At most six samples can be selected to generate a graph.
If there where more than six samples selected in the graphoptions screen (section 5.1.17) the �rst six
samples will be used to generate the graph.

Operations
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Figure 5.18: Custom attribute list screen

Operation Steps Result

Deselect
a sample
showed in the
graph

- Click the checkbox in front of the sample
you want to deselect

The sample will be removed from the
graph on the right side of the screen.

Select a
sample to be
shown in the
graph

- Click the checkbox in front of the sample
you want to show

The sample will be added to the graph
on the right side of the screen.

Change the
color of a line
in the graph.

- Select a color from any of the six drop-
down lists.

The line color will change to the se-
lected color.

Change the
line thickness

- Set the Line Thickness �eld. The graph line thickness will be
changed.

Print the
graph

- Click the Print button
- A standard Windows print dialog will ap-
pear, select the desired options and click
Print

The graph will be printed.

Save the pic-
ture

- Click the Save Picture button
- A standard Windows save dialog will ap-
pear, select the desired options and click
Save to save the data to a �le

The graph will be saved.

Possible errors

None

Related screens

None
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5.1.19 Database operations screen

Functional description

This screen consists of only buttons that will open up the closed sessions overview screen (section
5.1.20) with a list of matching sessions.

Figure 5.19: Database operations screen

Cautions and warnings

None

Operations
Operation Steps Result

Show all
closed ses-
sions

- Click Show Closed Sessions The closed sessions overview screen
(section 5.1.20) will appear with a list
of all closed sessions.

Show all
closed ses-
sions with
a certain
project name

- Click Show Closed Sessions For Project
- Enter the desired project name in the
message box
- Click Ok

The closed sessions overview screen
(section 5.1.20) will appear with a list
of all closed sessions with a project
name value containing a part of or
equal to the one just entered.

Show all
closed ses-
sions with a
certain name

- Click Show Closed Sessions With Name
- Enter the desired name in the message
box
- Click Ok

The closed sessions overview screen
(section 5.1.20) will appear with a list
of all closed sessions with a name that
contains the value just entered (i.e.
the entered value is a subset of the
session name).

Show all
closed ses-
sions with a
certain start
date

- Click Show Closed Sessions With Start-
date
- Enter the desired start date in the mes-
sage box (dd-mm-yyyy format)
- Click Ok

The closed sessions overview screen
(section 5.1.20) will appear with a list
of all closed sessions with a start date
equal to the value just entered.

Show all
closed ses-
sions with
a certain
closing date

- Click Show Closed Sessions With Clos-
ingdate
- Enter the desired closing date in the
message box (dd-mm-yyyy format)
- Click Ok

The closed sessions overview screen
(section 5.1.20) will appear with a list
of all closed sessions with a closing
date equal to the value just entered.

Possible errors
Error message Cause

Value is not a date The value you entered in the messagebox is not a date in
the dd-mm-yyyy format.

Related screens
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Reference topic Section

Closed sessions overview screen 5.1.20

5.1.20 Closed sessions overview screen

Functional description

This screen shows an overview of closed sessions matching certain criteria (see section 5.1.19). On the
left is a treeview of all matching sessions and their samples. On the right is a box with information on
the selected session.

Figure 5.20: Closed sessions overview screen

Cautions and warnings

None

Operations
Operation Steps Result

Show ses-
sion's sam-
ples

- Click the plus-sign in front of the desired
session

The tree will expand and show the
names of the samples for this session.

Hide session's
samples

- Click on the minus-sign in front of the
desired session

The tree will collapse and hide the
names of the samples for this session.

Show session
info

- Click on the name of the session you
would like to see info for, or, if it is ex-
panded, click on one of its samples

The session information on the right
will be updated and display informa-
tion for the selected session.

Open sample
overview
screen for a
session

- Double click on the name of the session
you would like to see info for, or, if it
is expanded, double click on one of its
samples
- Or click the session you would like to
see info for and click Show overview

The sample overview screen (section
5.1.10) will appear, containing the
samples for that session. You can only
change the physical attribute scores
there (i.e. not the scores for normal
attributes).

Possible errors

None

54 REFERENCES



Software User Manual bICEPS

Related screens
Reference topic Section

Database operations screen 5.1.19
Sample overview screen 5.1.10

5.1.21 Autosave

The autosave function is not a separate screen in ICEPS. It is a background function that constantly
monitors the data the user enters in all screens. When ICEPS should crash, for whatever reason, and
entered data has not yet been committed to the database, this function still has all the data from
before the crash.

Whenever you start ICEPS after a crash, upon logging in, a messagebox will appear asking if you
want you load the autosave. If you want to continue with the data you entered before the crash, click
yes in this dialog. If you click No, all data that was not committed to the database before the crash
will be lost (this includes open sample evaluations).

5.2 Administrator reference

This section serves as a reference for administrator users of the ICEPS system. Every screen in the
system is documented here, along with all possible operations in the screen, examples of usage, possible
errors and references to related screens.

5.2.1 Login screen

See section 5.1.1.

5.2.2 ICEPS main administration screen

Functional description

This is the main administration screen of the ICEPS system. It mainly serves two purposes: �rstly, to
display all active screens the user has opened. Secondly, to act as an interface from which the user
can open various screens that provide the main administrative functionality of ICEPS.
The top of the screen consists of a menu bar (displaying �le, options, window etc.) and a toolbar with
graphical buttons. All relevant screens can be opened from the menu. The toolbar acts as a shortcut
for the menu and contains buttons for most screens in ICEPS.
The center of the screen is called the "workspace" and will contain all open screens.
The bottom of the screen consists of a statusbar that will display short help messages for every toolbar
button.
Cautions and warnings

All screens that open up within the ICEPS main administration screen can be closed without closing
ICEPS. If you close the ICEPS main administration screen, however, ICEPS will be closed too.

Operations
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Figure 5.21: ICEPS main administration screen

Operation Steps Result

Open the new
protected at-
tribute list
screen

- Click on the toolbarbutton labeled New
Attribute list or select File->New At-
tribute list from the menu

The protected attribute list screen will
appear (section 5.2.4).

Open the
open pro-
tected at-
tribute list
screen

- Click on the toolbarbutton labeled Open
Attribute list or select File->Open At-
tribute list from the menu

The open protected attribute list
screen will appear (section 5.2.5).

Open the
manage
protected
attributes
screen

- Click on the toolbarbutton labeledMan-
age Attributes or select File->Manage
Attributes from the menu

The manage protected attributes
screen will appear (section 5.2.6).

Open the
manage phy-
sics attribute
list screen

- Click on the toolbarbutton labeledMan-
age Physics Attribute list or select File-
>Manage Physics Attribute list from the
menu

The manage physics attribute list
screen will appear (section 5.2.7).

Export
protected at-
tributes and
protected
attribute lists

- Click on the toolbarbutton labeled Ex-
port and click on Attributes & Lists or
select Options-> Export->Export Pro-
tected Attributes & Lists from the menu
- Now a standard Windows save �le dia-
log will appear. Browse for the location
where you want to save the �le and en-
ter a �lename in the Filename �eld, then
click Save

A �le with protected attributes and
protected attribute lists will be cre-
ated. This �le can be imported in the
ICEPS main screen (section 5.1.3).

Export phys-
ical attribute
list

- Click on the toolbarbutton labeled Ex-
port and click on Physics or select Op-
tions-> Export->Export List Of Physical
Attributes from the menu
- Now a standard Windows save �le dia-
log will appear. Browse for the location
where you want to save the �le and en-
ter a �lename in the Filename �eld, then
click Save

A �le with protected attributes and
protected attribute lists will be cre-
ated. This �le can be imported in the
ICEPS main screen (section 5.1.3).

Open export
log

- Click on the toolbarbutton labeled Ex-
port and click on Show Log or select Op-
tions->Show Log from the menu

The export log will appear. This log
shows a list exports along with export-
date and -time.

Open the
help interface

- Click on the toolbarbutton labeled Help
or select Help->ICEPS Help from the
menu

The help interface will appear.

Open the
change pass-
word screen

- Select Options->Change Password
from the menu

The change password screen will ap-
pear (section 5.1.4).

Tile open
screens

- Select Window ->Tile from the menu All open screens will be tiled.
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Cascade open
screens

- Select Window ->Cascade from the
menu

The open screens will be cascaded.

Close all open
screens

- Select Window ->Close All from the
menu

All open windows will be closed.

Bring a cer-
tain screen
to the fore-
ground

- Select Window from the menu
- Now click on the name of the screen you
want on the foreground

The selected screen is brought to the
foreground.

Possible errors

None

Related screens
Reference topic Section

Change password screen 5.1.4
Protected attribute list screen 5.2.4
Open protected attribute list screen 5.2.5
Manage protected attributes screen 5.2.6

5.2.3 Change password screen

See section 5.1.4

5.2.4 Protected attribute list screen

Functional description

This screen contains all functionality to compose a protected attribute list out of protected attributes.
The screen is used for both creating new protected attribute lists as well as for changing existing lists.

Figure 5.22: Protected attribute list screen
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Cautions and warnings

If you are changing an existing attribute list, upon saving, the old list version will be overwritten.

Operations
Operation Steps Result

Set attribute
list name

- Enter the desired name in the Attribute
list Name �eld

Upon saving this list, the entered
value will be used as identifying name
for the list.

Add pro-
tected at-
tribute(s)
to protected
attribute list

Alternative 1
- Select one or more (by holding ctrl and
clicking) attributes you want to add to
the list (you can pick multiple attributes
in multiple categories)
- Click Add
Alternative 2
- Select one or more (by holding ctrl and
clicking) attributes you want to add to
the list (all attributes must be in the same
category)
- Click and hold the left mouse button,
now drag to the same category on the
left side of the screen
- Release the left mouse button when in-
side the category list on the left

The selected attributes will have
moved from the lists on the right to
the lists on the left. Upon saving this
protected attribute list, all attributes
in the lists on the left will be in the
protected attribute list.

Remove at-
tribute(s)
from pro-
tected
attribute
list

- Select one or more (by holding ctrl and
clicking) attributes in the categories on
the left
- Click Remove

The selected attributes will have
moved from the lists on the left to the
lists on the right. Upon saving this
protected attribute list, all attributes
in the lists on the left will be in the
protected attribute list.

Open add
new pro-
tected
attribute
screen

- Click Add New Custom Attribute The add new protected attribute
screen (section 5.2.8) will appear.

Save pro-
tected
attribute
list

- Click Save List The protected attribute list screen
closes and the protected attribute list
is saved.

Cancel
changes/
creation

- Click Cancel or close the screen by click-
ing the cross in the right upper corner

A messagebox will ask for con�rma-
tion. Upon con�rmation the pro-
tected attribute list screen will close
and all changes will be discarded, if
you were in the process of creating a
new attribute list, no list is created.

Possible errors
Error message Cause

Please enter a name for the list You did not enter a name for the attribute list in the At-
tribute list Name �eld.

List cannot be empty You did not add any attributes to the attribute list.

Related screens
Reference topic Section

Add new protected attribute list screen 5.2.8

58 REFERENCES



Software User Manual bICEPS

5.2.5 Open protected attribute list screen

Functional description

This screen contains the functionality to open or delete a protected attribute list. It consists of a list
of available protected attribute lists and two buttons to open or delete a list.

Figure 5.23: Open protected attribute list screen

Cautions and warnings

Once you delete a protected attribute list, there is no way to recover it.

Operations
Operation Steps Result

Open pro-
tected at-
tribute list

- Select the desired protected attribute
list in the listbox
- Click Change List

The protected attribute list screen
(section 5.2.4 will appear.

Delete pro-
tected at-
tribute list

- Select the desired protected attribute
list in the listbox
- Click Delete List

A messagebox asking for con�rmation
will appear. Upon con�rmation the
selected attribute list will be deleted.

Possible errors

None

Related screens
Reference topic Section

Protected attribute list screen 5.2.4

5.2.6 Manage protected attributes screen

Functional description

This screen contains all the functionality to maintain your protected attributes. These protected at-
tributes can be used to form protected attribute lists.
Protected attributes can be added or deleted in this screen. Deleting an attribute will make it un-
available for use in newly created attribute lists. It will, however, stay available for existing protected
attribute lists.

Cautions and warnings

Once you delete a protected attribute, there is no way to recover it.
A deleted attribute that is still in a protected attribute list, and then is removed from that attribute
list, cannot be added again because it is deleted.
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Figure 5.24: Manage protected attributes screen

Operations
Operation Steps Result

Open add
new pro-
tected
attribute
screen

- Click Add Attribute The add new protected attribute
screen (section 5.2.8) will appear.

Delete at-
tribute

- Select one or more (by holding ctrl an
clicking) attributes you wish to delete
- Click Delete Attribute(s)

A message box will appear, asking for
con�rmation. Upon con�rmation, the
selected attributes will be deleted and
removed from the category lists.

Possible errors

None

Related screens
Reference topic Section

Add new protected attribute screen 5.2.8

5.2.7 Manage physics attribute list screen

Functional description

This screen contains all functionality to manage the list of physical attributes on which a sample should
be evaluated. It contains a list of physical attributes and two buttons to add and delete attributes.

Cautions and warnings

Once you delete a physical attribute there is no way to recover it.

Operations
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Figure 5.25: Manage physics attribute list screen

Operation Steps Result

Add attribute - Click Add Attributes
- Enter a name for the attribute in the
message box
- Click Ok

The entered name is added to the list
of physical attributes and is added to
the list in the screen.

Delete at-
tribute

- Select the desired attribute
- Click Delete Attribute

A message box asking for con�rmation
will appear. Upon con�rmation, the
selected attribute will be deleted and
remove from the list in the screen.

Possible errors
Error message Cause

There already exists a physics at-
tribute with the same name

You entered an attribute name in the �eld in the message-
box that already exists list of physical attributes.

Related screens

None

5.2.8 Add new protected attribute screen

Functional description

This screen o�ers the functionality to give a name and category for a new protected attribute. This
screen can only be brought up from the manage protected attributes screen (5.2.6).

Operations
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Figure 5.26: Add new protected attribute screen

Operation Steps Result

Set attribute
category

- Select the desired category from the
Category dropdownlist

Upon the "Add attribute" operation,
the selected category will be used as
category for the new attribute.

Set attribute
name

- Enter the desired name in the Attribute
Name �eld

Upon the "Add attribute" operation,
the entered name will be used as the
name for the new attribute.

Add attribute - Set the Category and Attribute Name
�elds
- Click Ok

The add new protected attribute
screen will close and the new attribute
is added to the list of its category.

Possible errors
Error message Cause

There already exist an attribute with
the same name and category

You entered an attribute name in the Attribute Name �eld
that already exists in the category selected in the Category
dropdownlist.

Related screens
Reference topic Section

Manage protected attributes screen 5.2.6
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Appendix A

Glossary

Term Meaning

User Any user of the ICEPS system
End-User The normal users of the ICEPS system, usually they

will be Sara Lee/DE co�ee experts
Administrator The administrator users of the ICEPS system
Sample A co�ee sample
Session A group of samples, grouped together because they

belong to the same project, are evaluated shortly after
one another and are evaluated with the same attribute
list

Attribute A property of a co�ee sample, belonging to a category
Category This can be: appearance, smell, taste or aftertaste
Attribute list A list of attributes on which a sample can be evaluated
Attribute score The value assigned by an end-user to an attribute
Physical attribute A property of a co�ee sample, speci�cally dealing with

physical properties like viscosity or temperature
Microsoft Excel A spreadsheet software package by Microsoft
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Index

attribute
custom, 18
add, 45
create, 46
disable, 45
manage, 31

evaluate, 10�11
physics, 26
manage, 56, 60

protected, 22�23
add, 59
create, 61
delete, 59
manage, 56

attribute list
custom, 19, 20
create, 31, 42
disable, 44
edit, 42
open, 31, 44

protected, 24, 25
create, 56, 57
delete, 59
edit, 57
open, 56, 59

autosave, 55

database, 31, 53

export
data, 27, 56
log, 35, 56
microsoft excel, 13, 35

graph, 13, 31, 50, 51

import, 17, 32
installation, 3

log, 35
login, 7, 21, 28

main screen, 30
administrator, 55

password
change, 8, 32, 33, 56

pca mapping, 15, 31, 46, 47

register, 6, 29

sample, 37

evaluation, 38
overview, 11, 40

session, 37
close, 13, 34
closed
overview, 16, 17, 54

create, 9�10, 31, 36
delete, 13, 34
export, 13, 34
open, 13, 31, 34
sample overview, 40

uninstallation, 5

visualization
graph, 13, 31, 50, 51
pca mapping, 15, 31, 46, 47
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