Software User Manual
Version 1.0.0

29-05-2006
Abstract

This is the Software User Manual (SUM) for the bICEPS project. This project is a part of the course Software Engineering (2IP40) at the Eindhoven University of Technology. The document confirms to the SUM guidelines of the software engineering standard, as stated by the European Space Agency (ESA).
This document describes the functionality of the software and instructs on how to use the software correctly.
Contents

Abstract

Document Status Sheet

Document Change Records

1 Introduction
   1.1 Intended readership
   1.2 Applicability
   1.3 Purpose
   1.4 How to use this document
   1.5 Related documents
   1.6 Conventions
   1.7 Problem reporting

2 Overview
   2.1 Overview of the software
   2.2 Administrator tasks
   2.3 End-User tasks

3 Installation
   3.1 Installation
   3.2 Uninstallation

4 Tutorials
   4.1 End-User tutorials
      4.1.1 Registering as a new user
      4.1.2 Logging in as end-user
      4.1.3 Changing your password
      4.1.4 Session creation and sample evaluation
      4.1.5 Opening, closing, deleting and exporting sessions
      4.1.6 Generating graphs and PCA mappings
      4.1.7 Generating closed session overviews
      4.1.8 Importing protected data
      4.1.9 Managing custom attributes
      4.1.10 Creating custom attribute lists
      4.1.11 Editing and deleting custom attribute lists
   4.2 Administrator tutorials
      4.2.1 Logging in as administrator
      4.2.2 Managing protected attributes
      4.2.3 Creating protected attribute lists
      4.2.4 Editing and deleting protected attribute lists
      4.2.5 Managing the list of physical attributes
      4.2.6 Exporting protected data
5 References

5.1 End-user reference

5.1.1 Login screen
5.1.2 Registration screen
5.1.3 bICEPS main screen
5.1.4 Change password screen
5.1.5 Open session screen
5.1.6 Show Log screen
5.1.7 Create new session screen
5.1.8 Session screen
5.1.9 Sample evaluation screen
5.1.10 Sample overview screen
5.1.11 Custom attribute list screen
5.1.12 Open custom attribute list screen
5.1.13 Manage custom attributes screen
5.1.14 Add new custom attribute screen
5.1.15 PCA mapping options screen
5.1.16 PCA mapping screen
5.1.17 Graph options screen
5.1.18 Graph screen
5.1.19 Database operations screen
5.1.20 Closed sessions overview screen
5.1.21 Autosave

5.2 Administrator reference

5.2.1 Login screen
5.2.2 bICEPS main administration screen
5.2.3 Change password screen
5.2.4 Protected attribute list screen
5.2.5 Open protected attribute list screen
5.2.6 Manage protected attributes screen
5.2.7 Manage physics attribute list screen
5.2.8 Add new protected attribute screen

A Glossary

IV CONTENTS
Document Status Sheet

Algemeen

Identification: /documenten/SUM/SUM-1.0.0.pdf
Authors: Kevin Jonkers & Marcel Steine
Document Status: Internally approved

Document History

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Reason of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.1.0</td>
<td>22-05-2006</td>
<td>Initial Version</td>
</tr>
<tr>
<td>1.0.0</td>
<td>29-05-2006</td>
<td>Changes after internal review</td>
</tr>
</tbody>
</table>
# Document Change Records

## Overview

DCR number: 1  
Date: 29-05-2006  
Authors: Kevin Jonkers & Marcel Steine  
Approved: Internally Approved  
Document Title: Software User Manual  
Identification: /documenten/SUM/SUM-1.0.0.pdf

## Changes

<table>
<thead>
<tr>
<th>Page</th>
<th>Paragraph</th>
<th>Reason of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>All</td>
<td>References to SAS removed</td>
</tr>
<tr>
<td>6</td>
<td>4.1.1</td>
<td>Only password is case-sensitive</td>
</tr>
<tr>
<td>8</td>
<td>4.1.3</td>
<td>&quot;Empty string&quot;, bad term for &quot;normal&quot; people</td>
</tr>
<tr>
<td>17</td>
<td>4.1.8</td>
<td>Fixed a grammatical error</td>
</tr>
<tr>
<td>23</td>
<td>4.2.3</td>
<td>Fixed a grammatical error</td>
</tr>
<tr>
<td>29</td>
<td>5.1.2</td>
<td>Fixed a grammatical error</td>
</tr>
<tr>
<td>40</td>
<td>5.1.9</td>
<td>Fixed a layout bug</td>
</tr>
<tr>
<td>56, 57</td>
<td>5.2.2</td>
<td>Fixed a layout bug</td>
</tr>
<tr>
<td>55</td>
<td>5.1.21</td>
<td>Added autosave section</td>
</tr>
</tbody>
</table>
Chapter 1

Introduction

1.1 Intended readership

This document is intended for end users and administrators of the ICEPS system. Both roles are formally described in [URD]. The reader is expected to have basic knowledge of the Microsoft Windows operating system.

1.2 Applicability

This document applies to the ICEPS system, version 1.0.0.

1.3 Purpose

The purpose of this document is to assist the user in learning the ICEPS system and to serve as a reference when using the ICEPS system.

1.4 How to use this document

First-time users are encouraged to read chapter 4 and follow each tutorial to develop a basic understanding of ICEPS. More experienced users can use the reference in chapter 5 to find out more about specific features of ICEPS.

1.5 Related documents

[URD] User Requirements Document
bICEPS
Mohammed El Kebir, Hans Wauters, Kevin Verbeek, Johan de Jong

1.6 Conventions

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>User</td>
<td>Any user using the system, this is either an End-User or an Administrator</td>
</tr>
<tr>
<td>End-User</td>
<td>The end users using the system</td>
</tr>
<tr>
<td>Administrator</td>
<td>The administrator using the system</td>
</tr>
<tr>
<td>Italics</td>
<td>All words in italics are texts on on-screen items</td>
</tr>
</tbody>
</table>

1.7 Problem reporting

Since the bICEPS team will be dissolved after completion of the ICEPS project, the issue of problem reporting is left to Sara Lee/DE.
Chapter 2

Overview

2.1 Overview of the software
ICEPS is a system for evaluating the quality of coffee samples by means of a certain attribute list. The results of these evaluations can then be exported to Microsoft Excel or be viewed in a graph or PCA-mapping.

2.2 Administrator tasks
An ICEPS administrator can create, change and delete protected attributes and protected attribute lists. The collection of attributes and attribute lists can be exported to a file for distribution to end-users. The administrator can also manage the list of physical attributes on which a sample is rated.

2.3 End-User tasks
An ICEPS end-user can create, change and delete custom attributes and custom attribute lists. These attributes and lists are only available for the end-user who created them. It is also possible to import a file with protected attributes and protected attribute lists, which can then be used for evaluating a sample. The end-user can also generate Microsoft Excel files containing the evaluations of samples, or generate graphs and PCA-mappings of the evaluations. For all evaluated samples, various overviews can be generated and viewed.
Chapter 3

Installation

This chapter describes how ICEPS can be installed and uninstalled on your system. Please note that only installation is discussed in this chapter. For more information on how to import an initial set of protected data, please see the tutorial or reference section of this document.

3.1 Installation

To begin the installation of ICEPS, double click on the executable named ICEPSsetup.exe. You should now see the screen as shown in figure 3.1. During the installation you can always go one step back by clicking the Back button.

![Figure 3.1: ICEPS installation screen](image)

Click Next to proceed, and the screen show in figure 3.2 will appear. This screen shows the location where ICEPS will be installed (C:\ICEPS by default). If you would like to change the installation folder, click on the Browse button and choose a new location. When the displayed destination folder is ok, click the button Next to proceed.

Now the screen shown in figure 3.3 will appear. Here you can choose the location for your start menu shortcuts. Click Browse to change the destination, by default it is ICEPS. If you don’t want the installer to create a folder in your start menu, check the check box labeled Don’t create a Start Menu folder.

Now click Next to proceed to the next step.

The additional tasks screen will appear (figure 3.4). If you want either a desktop icon or quick launch icon, check the appropriate check box(es). Finally click Next to proceed.

You will now see the overview screen, as shown in figure 3.5. Check if all the information is correct. If so, click Install to start copying the ICEPS files. If not, click Back to go back to previous steps.

When the installation completes you will see the screen shown in figure 3.6. If you click Finish the installer will close and ICEPS will launch.
Figure 3.2: ICEPS installation destination screen

Figure 3.3: ICEPS installation shortcuts screen

Figure 3.4: ICEPS installation additional tasks screen
3.2 Uninstallation

To uninstall ICEPS, locate the shortcut *Uninstall ICEPS* in your ICEPS start menu folder (if you did not create a start menu folder during installation, please use the Add/Remove Programs screen in Windows). Click this shortcut to start the uninstall program. Click Yes to uninstall ICEPS, if everything went right, a dialog will appear, telling ICEPS was uninstalled successfully.
Chapter 4

Tutorials

4.1 End-User tutorials

4.1.1 Registering as a new user

Functional description
This tutorial describes how to register yourself as a new user in ICEPS.

Cautions and warnings
The password is case-sensitive.

Procedure
Before you start, please be sure to know:

- Your employee number
- A password (optional)

Start ICEPS, the screen as shown in figure 4.1 will show up.

![Figure 4.1: Login screen](image)

Since you want to register, click on the button labeled Register new user. This will bring up the screen as shown in figure 4.2.

Now please enter the following things:

- For Name, enter your real name
- For Username, enter your employee number
- For Password, enter a password (this is optional)
If you have entered anything in the previous step, enter the same password for Confirm Password. If you have left Password empty, do not fill in anything for Confirm Password.

Finally, click on the button labeled Register. You are now registered as an end-user for ICEPS and can login (section 4.1.2).

Likely errors

- If the values entered in Password and Confirm Password are not the same, a messagebox will show up, saying that the passwords do not match. You should clear the password fields and enter the password again.

4.1.2 Logging in as end-user

Functional description

This tutorial describes how to login as an end-user in ICEPS.

Cautions and warnings

Be sure to be a registered user in the system (see section 4.1.1).

Procedure

Before you start, please be sure to know:

- Your employee number
- Your password (if you supplied one during registration)

Start ICEPS, the screen as shown in figure 4.1 will show.

Now enter the following information:

- For Username enter your employee number
- For Password enter the password you supplied during registration. If you did not supply a password during registration, leave this field empty.

Now click on Login and the ICEPS main form will show, see figure 4.3.

Likely errors

- If the password you supplied is not correct for the given username, a messagebox will show up, saying that the password is incorrect. Please re-enter your password and click Login again to retry to login.
4.1.3 Changing your password

Functional description
This tutorial describes how to change the password you use for logging in to ICEPS.

Cautions and warnings
You have to be logged in to follow this tutorial.
Remember your new password, as there is no way to retrieve it if you forget it.

Procedure
In the ICEPS mainscreen select Options -> Change Password from the menu. The change password screen will appear, as shown in figure 4.4.

![Change Password Screen](image)

Figure 4.4: Change password screen

In the Old password field, fill in your current password (leave empty if you do not have a password set). In the New password and Confirm password fields, enter your new desired password (leave empty if you want to use no password). Make sure you type the same password in both fields. Now click Ok
to confirm the change. When you start ICEPS the next time, you will have to login with your new password.

**Likely errors**

- If you receive the error "The supplied passwords do not match", the passwords filled in in the New password and Confirm password fields are not the same. Re-enter your password and click Ok to try again.

### 4.1.4 Session creation and sample evaluation

**Functional description**

This tutorial describes how to create a session and evaluate samples for this session.

**Cautions and warnings**

You have to be logged in to follow this tutorial. The attribute lists seen in screenshots in this tutorial will probably not match the ones seen on the user's screen.

**Procedure**

In the ICEPS mainscreen click on New Session in the toolbar or click on File -> New Session in the menu. The screen shown in figure 4.5 will show up.

![Create New Session](image)

**Figure 4.5: New session screen**

Enter the following information:

- For **Session Name** enter an identifying name for the session
- For **Project Name** enter the name of the corresponding project (optional)
- For **Project Number** enter the number of the corresponding project (optional)
- For **Attribute List** choose the attribute list you want to use for evaluating the samples in this session

Now click on the button labeled Ok and the screen shown in figure 4.6 will appear.

This is the session overview screen. In this screen you will see all relevant information for a session and a list of all samples that have been evaluated in this session. We will now first add a description to the session and save it.

To add a description, enter some text in the **Description** field in the session overview screen. This
description will be automatically saved.

Now that we have all the relevant session info filled in, we can start a sample evaluation. Click on the button labeled **New Sample**, this will bring up a message box asking for a name for the sample. Fill in an appropriate name and click **Ok**. Now, the sample evaluation screen, shown in figure 4.7 will show up.

In this screen you can evaluate each attribute. All the attributes are placed on a tab for their category. Evaluating can be done in two ways:

- You can drag the slider next to an attribute name, the corresponding value will be displayed in
You can directly enter a value in the textfield on the right, the slider will accordingly move to
the corresponding position.

Now evaluate every attribute on the tabs labelled Appearance, Smell, Taste and Aftertaste (one or
more of these may be absent if the attribute list does not have any attributes in these categories) and
finally select the tab Remarks.

Now that you have evaluated all attributes you need to enter a final quality mark for the sample
and optionally any remarks. Enter the quality mark in the Quality Mark field, this can be number
ranging from 0 to 10, with two decimal places. It does not matter if you use a comma or dot as a
decimal separator, it will be auto corrected once you leave the field.

Enter any remarks in the Remarks field if you have any.

An optional last step is to add physical data for this sample, this can be done on the Physics tab
(this tab can be absent if no physics attribute list is present). Just enter the appropriate values in the
textfields.

To finish the evaluation, click on the button labeled Save evaluation. The session overview screen
will now contain a sample with the name you just supplied in the list of samples on the right.

If you want an overview of all samples in your session, you can click on the button labeled Sample
Overview in the session overview screen. This will bring up the screen shown in figure 4.8.

![Figure 4.8: Sample overview screen](image)

This shows all samples with their respective scores for each attribute. In this overview you can
change the attribute evaluations by double clicking on the desired cell and entering a new value. To
save any changes made here, you have to click the Save Changes button.
The overview can be printed by clicking the button labeled Print. This will bring up a standard Windows print dialog.
For more information on generating graphs from the sample overview screen, see section 4.1.6

Likely errors
- If you did not evaluate all attributes, or did not enter a quality mark, you will get a warning when clicking Save Evaluation. This warning states that the sample will be discarded because not all attributes are evaluated. To save the sample you need to click Cancel in this messagebox and evaluate all attributes and give a quality mark.

4.1.5 Opening, closing, deleting and exporting sessions

Functional description
This tutorial describes how previously created sessions can be opened, closed (finalized), deleted and exported to Microsoft Excel files.

Cautions and warnings
You have to be logged in to follow this tutorial.
Please be sure to have one or more open sessions with at least one evaluated sample in your system.
Also, note that when you close (finalize) a session, it can never be opened again. Furthermore, deleted sessions cannot be recovered. So please be careful when following this tutorial, not to close or delete sessions on which you still want to work.

Procedure
To do any of the operations mentioned in the functional description, first click on the toolbar button Open Session or click on File -> Open Session in the menu. This will bring up the open session screen, as shown in figure 4.9

![Figure 4.9: Session open screen](image)

When you select a session in the list, all relevant session information will be displayed in the Session Info box below the list.
To open a session, click on the desired session in the list and then click on Open Session. This will bring up the session overview screen which we discussed earlier.

To delete a session, click on the desired session in the list and then click on Delete Session. Now, a messagebox will show up, asking for confirmation. If you click Yes, the session will be deleted. Clicking No will not delete the session.

To close a session, click on the desired session and then click on Finalize Session. Now, a messagebox will show up, asking for confirmation. If you click Yes, the session will be closed. Clicking No will not close the session.

Yes, the session will be closed. Clicking No will not close the session.

To export a session and its sample data, click on the desired session and then click on Export. You now have the option to choose between exporting to a Microsoft Excel file or to show the Export Log. The first option will bring up a standard Windows save file dialog. Choose a desired filename here and click Save to save the data to a file. The second option option will bring up the export log screen. The export log screen shows the export dates of the selected session.

Likely errors

None

4.1.6 Generating graphs and PCA mappings

Functional description

This tutorial describes how to generate graphs and PCA mappings from samples.

Cautions and warnings

You have to be logged in to follow this tutorial.
Please be sure to have some evaluated samples in your system. To compare samples in one graph, the samples need to be evaluated with the same attribute list.

Procedure

Graphs can be generated in two ways:

- Based on all samples in one session, this can be done from the sample overview screen
- Based on arbitrary samples (from different sessions), evaluated with the same attribute list. This can be done from the toolbar or menu.

We will discuss both methods, starting with the first method.

Bring up a sample overview screen and click on the button labeled Show Graph. Now the sample data graph screen shows up. We will discuss how this screen works further on in this section.

We will now show how to generate a graph from the toolbar/menu.
To do this, click on the toolbar button labeled Visualization and then on Graph. Or, alternatively, click on Visualization -> Graph in the menu. This brings up the graph options screen, shown in figure 4.10.

In the Attribute List dropdown box, you can select for which attribute list you want to compare samples. If you select any attribute list from the dropdown box, the samples, evaluated with this attribute list, will show up, ordered by their containing sessions.

To select the samples you want in your graph, first expand the sessions that contain the desired samples. You can do this by clicking on the plus-sign in front of a session name.
You can now select the desired samples by clicking on the check boxes in front of the sample.
Another option is to select an entire session (and thus all the samples it contains), by clicking on the
When you finished selecting samples, click on the button labeled *Generate Graph* to generate the graph. This will bring up the sample data graph screen, as shown in Figure 4.11. In this screen you can influence what is displayed in the graph, print the graph and export the graph as a graphical file.

To display samples, select them by clicking the check box in front of the desired samples in the list titled *Show Samples*. At most six samples can be displayed at a time. The colors for each sample line can be changed by changing the values in the dropdown boxes named *Color 1*, *Color 2*, etc. The thickness of graph lines can be changed by entering a positive value for *Line Thickness*.

To print the graph, click on the button labeled *Print*. This brings up a standard Windows print dialog.
To export the graph to a graphical file (.bmp or .jpg), click on the button labeled Save Picture. This brings up a standard Windows save file dialog. Enter the desired filename and choose the filetype in the dropdown box below the filename and click on Save. Now the graph is exported to a graphical file and can be opened using compatible graphics software.

To generate PCA mappings, click on Visualization and then PCA Mapping in the toolbar. Or, alternatively, click on Visualization -> PCA Mapping in the menu. Now, the PCA mapping options screen will show. This screen is operated the same way as the graph options screen, so we will not discuss it here again.

After clicking on Generate PCA Mapping. The PCA mapping screen will appear, as shown in figure 4.12

![PCA mapping screen](image)

Figure 4.12: PCA mapping screen

The PCA mapping screen offers a lot of functionality which we will not discuss here. For more information see section 5.1.16

Likely errors

- If you try to select more than six samples in the sample data graph screen, the seventh selected sample will not become selected. To display the sample in the graph, deselect one or more other samples first.

4.1.7 Generating closed session overviews

Functional description

This tutorial describes how to generate sample overviews of closed sessions.

Cautions and warnings

You have to be logged in to follow this tutorial.

Please make sure you have closed at least one session before starting this tutorial.

Procedure

Various overviews of sample data from closed sessions can be generated from the database operations
Click on the toolbar button Database or click on Database -> Show Database Operations in the menu and the database operations screen will show up. On this screen, show in figure 4.13 the various options for generating closed session overviews are shown.

![Database Operations Screen](image)

**Figure 4.13: Database operations screen**

As all the descriptions on the buttons explain themselves, we will not go into detail here. After you clicked one of the buttons (and filled in any requested data), the closed session overview screen will appear. This screen is shown in figure 4.14.

![Closed Session Overview Screen](image)

**Figure 4.14: Closed session overview screen**

To see more information on a session, select the session or one of its samples in the listbox on the left. The session information on the right will be updated accordingly. Samples can be made visible by clicking the plus-sign in front of a session name.

To see more detailed information about the samples in a certain session, double click on the session or anyone of its samples. Now the sample overview screen will appear. We already discussed this screen in section 4.1.4 so look there for more information on how it works. The only difference when
using this screen with a closed session, as opposed to an open session, is that only physical attributes can be changed. The regular attributes can not be changed anymore.

Likely errors

- If the closed session overview screen does not show any sessions, you probably supplied information (project name, session name, startdate or closingdate) that does not have any related closed sessions.

4.1.8 Importing protected data

Functional description
This tutorial describes how to import protected data that has been exported by an administrator. The protected data is either a file with protected attributes and protected attribute lists, or a file with a list of physical attributes.

Cautions and warnings
You have to be logged in to follow this tutorial.
Once you have imported files, old attribute lists or physical attributes that were previously available but are not in the imported data, cannot be used for new sessions.

Procedure
The steps for importing both types of data are almost the same. Therefore we will only discuss the steps once and indicate where both procedures differ.
To import any data file, first click on the toolbar button labeled Import and then choose the desired type of data to import. Another option is to select Options -> Import Protected Attributes Lists or Options -> Import List Of Physical Attributes from the menu. This is the only step where both procedures differ, so be sure to pick the right option.

After selecting one of the previously mentioned options, a standard Windows file open dialog will appear. Browse for the location of the file you want to import and select it, so it’s name shows up in the Filename field. Then click Ok.

The file will now be imported into your local database. All messages generated by the import process will be displayed in a new window. Inspect the messages to see if everything imported fine. You can immediately use the newly imported data for new sessions.

Likely errors

- If the file you selected is corrupt, an errorbox will show up, telling that the file could not be imported. Please be sure to use a valid file exported and distributed by an administrator.

- If the log window shows any errors, they are self explanatory.

4.1.9 Managing custom attributes

Functional description
This tutorial describes how to manage (create and delete) your custom attributes. These custom attributes can later on be used to form a custom attribute list.

Cautions and warnings
You have to be logged in to follow this tutorial.
Please note that once you deleted a custom attribute, it will still be available in previously created custom attribute lists but cannot be used anymore in newly created custom attribute lists.
Procedure
To manage your custom attributes, click on the toolbar button labeled *Manage Attributes* or, alternatively, select *Files -> Manage Attributes* from the menu. This will bring up the manage custom attributes screen, as shown in figure 4.15.

![Manage custom attributes screen](image1)

Figure 4.15: Manage custom attributes screen

All custom attributes are displayed in their corresponding category. You are now able to add custom attributes and to disable custom attributes. Disabling an attribute will make it unavailable for use in a newly created custom attribute list. It will still be listed in previously created custom attribute lists though.

To add a new custom attribute, click on the button labeled *Add Attribute*, the add new custom attribute screen will show up, as shown in figure 4.16.

![Add new custom attribute screen](image2)

Figure 4.16: Add new custom attribute screen

First, select the desired category for the new custom attribute in the *Category* dropdown list. Now fill in a name for the new custom attribute in the *Attribute Name* field. Finally, click *Ok* to add the
To disable a custom attribute, first, select the desired attribute. It is also possible to select more than one attribute at a time: If the attributes you want to select are in the same category, hold ctrl and click on the desired attributes. If the attributes are in different categories you can just click them. A combination of both is possible, too. Finally, to disable the selected custom attribute(s), click on the button labeled Disable Attributes. Now, a messagebox will appear, asking for confirmation. Click on Yes to confirm the disabling of the custom attributes, or click on No to abort the operation.

Likely errors

- While adding a new custom attribute: If you enter an attribute name in the Attribute Name field that already exists in the selected category, an error message will show. Please change your attribute name in one that is not yet in use.

4.1.10 Creating custom attribute lists

Functional description
This tutorial describes how to create a new custom attribute list. A custom attribute list can consist of a mix of protected and custom attributes.

Cautions and warnings
You have to be logged in to follow this tutorial.

Procedure
To create a new custom attribute list, click on the toolbar button labeled New Attribute list or, alternatively, select File -> New Attribute list from the menu. This will bring up the create custom attribute list screen as shown in figure 4.17.

The first thing to do is fill in a name for the new custom attribute list in the Attribute list Name field. Please note that if you fill in a name of an already existing list, this list will be overwritten.

Now you can add attributes to the list. On the left are four category-lists, this is your custom attribute list. On the right are two tabs with four category-lists each. To add a protected attribute to your custom attribute list, select the tab labeled Protected Attributes. Next, select one or more attributes (multiple attributes can be selected by holding the ctrl key and clicking), and click the button labeled Add. The selected attributes will now move to your custom attribute list. An alternative way to add attributes is to select one or more attributes in one category and drag them to the same category in your custom attribute list on the left.
To add a custom attribute to your custom attribute list, select the tab labeled Custom Attributes. Next, follow the same steps as above.

To remove an attribute from your custom attribute list, select one or more attributes in the lists on the left and click the button labeled Remove. The selected attributes will now move back to the right.

To finish creating your custom attribute list, click on the button labeled Save List. The list will now be saved and available for use in newly created sessions.

Likely errors

- If the name supplied in the Attribute List Name field already exists for another custom attribute list, upon saving, a warning message will appear. If you click Yes, the previous version of the attribute list with this name will be overwritten.
4.1.11 Editing and deleting custom attribute lists

**Functional description**
This tutorial describes how to edit or delete any of your custom attribute lists.

**Cautions and warnings**
You have to be logged in to follow this tutorial.
Please note that once you delete a custom attribute list, it will still be available in previously created sessions (which are using that custom attribute list). Also, when you edit a custom attribute list, the old version will still be used in previously created sessions (which are using that custom attribute list).

**Procedure**
To edit or delete a custom attribute list, first click on the toolbar button labeled *Open Attribute list*, or, alternatively, select *File->Open Attribute list* from the menu. Now the custom attribute lists screen will appear, as shown in figure 4.18.

To edit a custom attribute list, select a name in the list and click the button labeled *Change List*. Now the change custom attribute list screen will appear, and you can edit your list as described in 4.1.10.

To delete a custom attribute list, select a name in the list and click the button labeled *Disable List*. Now a messagebox asking for confirmation will show up. Click Yes to disable the list, or click No to abort the operation. If you clicked Yes the custom attribute list will now disappear from the list, otherwise, nothing happens.

**Likely errors**
None
4.2 Administrator tutorials

4.2.1 Logging in as administrator

**Functional description**
This tutorial describes how to login as an administrator.

**Cautions and warnings**
Please be sure to have an administrator password supplied to you. An administrator will always have a non-empty password.

**Procedure**
Start ICEPS, the screen as shown in figure 4.19 will show.

Now enter the following information:

- For **Username** enter "admin" (without the quotes).
- For **Password** enter the password that was supplied to you.
Now click on *Login* and the ICEPS main administration form will show, see figure 4.20.

![ICEPS Main Administration Screen](image)

**Figure 4.20: ICEPS main administration screen**

**Likely errors**

- If you did not fill in "admin" in the *Username* field, you cannot login as administrator.
- If you did not supply the right password in the *Password* field, you cannot login. Please check your password and re-enter it.

### 4.2.2 Managing protected attributes

**Functional description**

This tutorial describes how to manage (create and delete) protected attributes. These protected attributes can later on be used to form attribute lists.

**Cautions and warnings**

You have to be logged in as administrator to follow this tutorial. Please note that once you deleted a protected attribute, it will still be available in previously created attribute lists but cannot be used in newly created attribute lists.

**Procedure**

To manage protected attributes, click on the toolbar button labeled *Manage Attributes* or, alternatively, select *Files* -> *Manage Attributes* from the menu. This will bring up the manage protected attributes screen, as shown in figure 4.21.

All protected attributes are displayed in their corresponding category. You are now able to add protected attributes and to delete protected attributes. Deleting an attribute will make it unavailable for use in a newly created attribute lists. It will still be listed in previously created attribute lists though.
To add a new protected attribute, click on the button labeled *Add Attribute*, the add new protected attribute screen will show up, as shown in figure 4.22.

First, select the desired category for the new protected attribute in the *Category* dropdown list. Now fill in a name for the new protected attribute in the *Attribute Name* field. Finally, click *Ok* to add the protected attribute to the list.

To delete a protected attribute, first, select the desired attribute. It is also possible to select more than one attribute at a time: If the attributes you want to select are in the same category, hold ctrl and click on the desired attributes. If the attributes are in different categories you can just click them. A combination of both is possible, too. Finally, to delete the selected protected attribute(s), click on the button labeled *Delete Attributes*. Now, a message box will appear, asking for confirmation. Click on *Yes* to confirm the deletion of the protected attributes, or click on *No* to abort the operation.

**Likely errors**
• While adding a new protected attribute: If you enter an attribute name in the Attribute Name field that already exists in the selected category, an error message will show. Please change your attribute name into one that is not yet in use.

4.2.3 Creating protected attribute lists

Functional description
This tutorial describes how to create a new protected attribute list. A protected attribute list contains only protected attributes.

Cautions and warnings
You have to be logged in as administrator to follow this tutorial.

Procedure
To create a new protected attribute list, click on the toolbar button labeled New Attribute list or, alternatively, select File -> New Attribute list from the menu. This will bring up the create protected attribute list screen as shown in figure 4.23.

Figure 4.23: Create protected attribute list screen

The first thing to do, is fill in a name for the new protected attribute list in the Attribute list Name field. Please note that if you fill in a name of an already existing list, this list will be overwritten.

Now you can add attributes to the list. On the left are four category-lists, this is your protected attribute list. On the right are also four category-lists. To add a protected attribute to your protected attribute list, select one or more attributes on the right (multiple attributes can be selected by holding the ctrl key and clicking), and click the button labeled Add. The selected attributes will now move to your protected attribute list. An alternative way to add attributes is to select one or more attributes
in one category and drag them to the same category in your protected attribute list on the left.

To remove an attribute from your protected attribute list, select one or more attributes in the lists on the left and click the button labeled Remove. The selected attributes will now move back to the right.

To finish creating your protected attribute list, click on the button labeled Save List. The list will now be saved and can be exported (see section 4.2.6).

Likely errors
- If the name supplied in the Attribute list Name field already exists for another protected attribute list, upon saving, a warning message will appear. If you click Ok, the previous version of the attribute list with this name will be overwritten.

4.2.4 Editing and deleting protected attribute lists

Functional description
This tutorial describes how to edit or delete any of the protected attribute lists.

Cautions and warnings
You have to be logged in as administrator to follow this tutorial.

Procedure

To edit or delete a protected attribute list, first click on the toolbar button labeled Open Attribute list, or, alternatively, select File->Open Attribute list from the menu. Now the protected attribute lists screen will appear, as shown in figure 4.24.

![Protected Attribute Lists](image)

Figure 4.24: Protected attribute lists screen

To edit a protected attribute list, select a name in the list and click the button labeled Change List. Now the change protected attribute list screen will appear, and you can edit your list as described in 4.2.3.

To delete a protected attribute list, select a name in the list and click the button labeled Delete List. Now a message box asking for confirmation will show up. Click Yes to delete the list, or click No to abort the operation. If you clicked Yes the protected attribute list will now disappear from the list, otherwise, nothing happens.
4.2.5 Managing the list of physical attributes

Functional description
This tutorial describes how to manage the list of physics attributes.

Cautions and warnings
You have to be logged in as administrator to follow this tutorial.
Please note that once you delete a physics attribute from the list, it is not possible to recover it.

Procedure
To open the current list of physical attributes, click on the toolbar button labeled Manage Physics Attribute list. Now the manage physics attribute list screen will appear, as shown in figure 4.25.

To add a new physics attribute to the list, click on the button labeled Add Attribute. This will bring up the add new physics attribute screen, shown in figure 4.26.

Now fill in a name for the new attribute in the Attribute Name field. To add the attribute to the list, click the button labeled Ok. To abort the operation, click Cancel.

To delete a physics attribute, select an attribute in the manage physics attribute screen. To delete the selected attribute, click the button labeled Delete Attribute. A messagebox will now ask for confirmation. To really delete the attribute, click the button labeled Yes in this messagebox. To abort the operation, click No. If you clicked Yes, the attribute will disappear from the list.

Likely errors
None
While adding a new physics attribute: If you enter an attribute name in the Attribute Name field that already exists in the physics attribute list, an error message will show. Please change your attribute name into one that is not yet in use.

4.2.6 Exporting protected data

Functional description
This tutorial describes how to export protected attributes and protected attribute lists, as well as the physics attribute list to a file. This file can then be imported by an ICEPS end-user.

Cautions and warnings
You have to be logged in as administrator to follow this tutorial.

Procedure
The steps for exporting both types of data are almost the same. Therefore we will only discuss the steps once and indicate where both procedures differ.

To export any data to a file, first click on the toolbar button labeled Export and then choose the desired type of data to export. Another option is to select Options -> Export Protected Attributes Lists or Options -> Export List Of Physical Attributes from the menu. This is the only step where both procedures differ, so be sure to pick the right option.

After selecting one of the previously mentioned options, a standard Windows file save dialog will appear. Browse for the location where you want to save the file and enter the desired filename in the Filename textbox. Then click Ok.

The protected data will now be exported to an ICEPS readable file. These files can then be distributed to end-users, who can import them.

Likely errors
None
Chapter 5

References

This chapter is divided into two sections, one for end-users and one for administrators. Login and registration procedures are only described in the end-user reference.

5.1 End-user reference

This section serves as a reference for end-users of the ICEPS system. Every screen in the system is documented here, along with all possible operations in the screen, examples of usage, possible errors and references to related screens.

5.1.1 Login screen

Functional description
This screen is the first screen that shows up when you start ICEPS. It is used to enter the user’s username and password so the user can login to the ICEPS system. Also, there is a registration button for new users.

![Login screen](image)

Figure 5.1: Login screen

Cautions and warnings
None

Operations
<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set login username</td>
<td>- Enter the username in the <strong>Username</strong> field</td>
<td>Upon the &quot;Login&quot; operation, the entered username will be used as username.</td>
</tr>
<tr>
<td>Set login password</td>
<td>- Enter the password in the <strong>Password</strong> field</td>
<td>Upon the &quot;Login&quot; operation, the entered password will be used as password.</td>
</tr>
<tr>
<td>Login</td>
<td>- Set the username and password (possibly empty)</td>
<td>The login screen will close and the ICEPS main screen will appear, you are logged in.</td>
</tr>
<tr>
<td>Close ICEPS</td>
<td>- Click <strong>Cancel</strong></td>
<td>ICEPS will close.</td>
</tr>
<tr>
<td>Open registration screen</td>
<td>- Click <strong>Register new user</strong></td>
<td>The registration screen will appear, see section 5.1.2</td>
</tr>
</tbody>
</table>

### Possible errors

<table>
<thead>
<tr>
<th>Error message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td>Please fill in a username</td>
<td>You did not supply a username in the <strong>Username</strong> field.</td>
</tr>
<tr>
<td>Username or password incorrect</td>
<td>The supplied username is not registered, or your password is incorrect.</td>
</tr>
</tbody>
</table>

### Related screens

<table>
<thead>
<tr>
<th>Reference topic</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Registration screen</td>
<td>5.1.2</td>
</tr>
<tr>
<td>ICEPS main screen</td>
<td>5.1.3</td>
</tr>
</tbody>
</table>

### 5.1.2 Registration screen

#### Functional description

This screen offers the functionality for registering a new user in the ICEPS system on your local computer.

![Figure 5.2: Registration screen](image)

### Cautions and warnings

Once you registered on a computer, you are only registered on that very computer. If you want to work in ICEPS again on another computer, you will have to register again.

### Operations
<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set name</td>
<td>- Enter your real name in the Name field</td>
<td>Upon the &quot;Register&quot; operation, the entered name will be used as name.</td>
</tr>
<tr>
<td>Set username</td>
<td>- Enter your employee number in the Username field</td>
<td>Upon the &quot;Register&quot; operation, the entered employee number will be used as username.</td>
</tr>
<tr>
<td>Set password</td>
<td>- Enter your desired password in the Password field. If you do not want to use a password, leave this field empty. - Enter the password you entered in the previous step again in the Confirm Password field. If you did not enter a password in the previous step, leave this field empty.</td>
<td>Upon the &quot;Register&quot; operation, the entered password will be used as password.</td>
</tr>
<tr>
<td>Register</td>
<td>- Set all fields in the screen - Click Register</td>
<td>The login screen will appear, and you can now login with the username and password you just supplied.</td>
</tr>
<tr>
<td>Cancel registration</td>
<td>- Click Cancel</td>
<td>The login screen will appear, you did not register as a new user.</td>
</tr>
</tbody>
</table>

Possible errors

<table>
<thead>
<tr>
<th>Error message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td>Please fill in your name</td>
<td>You did not supply your real name in the Name field</td>
</tr>
<tr>
<td>Please fill in a username</td>
<td>You did not supply your employee number in the Username field</td>
</tr>
<tr>
<td>The supplied passwords do not match</td>
<td>The passwords in the Password and Confirm Password fields are not the same</td>
</tr>
</tbody>
</table>

Related screens

<table>
<thead>
<tr>
<th>Reference topic</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Login screen</td>
<td>5.1.1</td>
</tr>
</tbody>
</table>

5.1.3 ICEPS main screen

Functional description

This is the main screen of the ICEPS system. It mainly serves two purposes: firstly, to display all active screens the user has opened. Secondly, to act as an interface from which the user can open various screens that provide the main functionality of ICEPS.

The top of the screen consists of a menu bar (displaying file, visualization, database etc.) and a toolbar with graphical buttons. All relevant screens can be opened from the menu. The toolbar acts as a shortcut for the menu and contains buttons for most screens in ICEPS.

The center of the screen is called the "workspace" and will contain all open screens.

The bottom of the screen consists of a statusbar that will display short help messages for every toolbar button.

Cautions and warnings

All screens that open up within the ICEPS main screen can be closed without closing ICEPS. If you close the ICEPS main screen, however, ICEPS will be closed too.

Operations
### Operation Steps Result

<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the new session screen</td>
<td>- Click on the toolbar button labeled <em>New Session</em> or select <em>File-&gt;New Session</em> from the menu</td>
<td>The create new session screen will appear (section 5.1.7).</td>
</tr>
<tr>
<td>Open the open session screen</td>
<td>- Click on the toolbar button labeled <em>Open Session</em> or select <em>File-&gt;Open Session</em> from the menu</td>
<td>The open session screen will appear (section 5.1.5).</td>
</tr>
<tr>
<td>Open the new custom attribute list screen</td>
<td>- Click on the toolbar button labeled <em>New Attribute list</em> or select <em>File-&gt;New Attribute list</em> from the menu</td>
<td>The custom attribute list screen will appear (section 5.1.11).</td>
</tr>
<tr>
<td>Open the open custom attribute list screen</td>
<td>- Click on the toolbar button labeled <em>Open Attribute list</em> or select <em>File-&gt;Open Attribute list</em> from the menu</td>
<td>The open custom attribute list screen will appear (section 5.1.12).</td>
</tr>
<tr>
<td>Open the manage custom attributes screen</td>
<td>- Click on the toolbar button labeled <em>Manage Attributes</em> or select <em>File-&gt;Manage Attributes</em> from the menu</td>
<td>The manage custom attributes screen will appear (section 5.1.13).</td>
</tr>
<tr>
<td>Open the PCA mapping options screen</td>
<td>- Click on the toolbar button labeled <em>Visualization</em> and click on <em>PCA Mapping</em> or select <em>Visualization-&gt;PCA Mapping</em> from the menu</td>
<td>The pca mapping options screen will appear (section 5.1.15).</td>
</tr>
<tr>
<td>Open the graph options screen</td>
<td>- Click on the toolbar button labeled <em>Visualization</em> and click on <em>Graph</em> or select <em>Visualization-&gt;Graph</em> from the menu</td>
<td>The graph options screen will appear (section 5.1.17).</td>
</tr>
<tr>
<td>Open the database operations screen</td>
<td>- Click on the toolbar button labeled <em>Database</em> or select <em>Database-&gt;Show Database Operations</em> from the menu</td>
<td>The database operations screen will appear (section 5.1.19).</td>
</tr>
</tbody>
</table>
Import protected attributes and protected attribute lists
- Click on the toolbar button labeled Import and click on Attributes & Lists or select Options->Import Protected Attributes & Lists from the menu
- Now a standard Windows open file dialog will appear. Browse for the file you want to import and click on it, then click Open

The file with protected attributes and protected attribute lists will be imported. The contents of the files (attributes and attribute lists) can now be used for new sessions.

Import physical attribute list
- Click on the toolbar button labeled Import and click on Physics or select Options->Import List Of Physical Attributes from the menu
- Now a standard Windows open file dialog will appear. Browse for the file you want to import and click on it, then click Open

The file with a list of physical attributes will be imported. This list will now be used for all samples created in the future.

Open the log file
- Select Options->Show Log from the menu

The show log screen will appear (section 5.1.6)

Open the help interface
- Click on the toolbar button labeled Help or select Help->ICEPS Help from the menu

The help interface will appear.

Open the change password screen
- Select Options->Change Password from the menu

The change password screen will appear (section 5.1.4).

Tile open screens
- Select Window->Tile from the menu

All open screens will be tiled.

Cascade open screens
- Select Window->Cascade from the menu

The open screens will be cascaded.

Close all open screens
- Select Window->Close All from the menu

All open windows will be closed.

Bring a certain screen to the foreground
- Select Window from the menu
- Now click on the name of the screen you want on the foreground

The selected screen is brought to the foreground.

Possible errors
None

Related screens
Reference topic
Change password screen
Open session screen
Show log screen
Create new session screen
Custom attribute list screen
Open custom attribute list screen
Manage custom attributes screen
PCA mapping options screen
Graph options screen
Database operations screen

Section
5.1.4
5.1.5
5.1.6
5.1.7
5.1.11
5.1.12
5.1.13
5.1.15
5.1.17
5.1.19
5.1.4 Change password screen

Functional description
This screen offers the possibility to change the password you use to login.

Cautions and warnings
There is no way to retrieve your password if you forget it, so please make sure you remember your new password.

Operations

<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set current password</td>
<td>- Enter your current password in the Old Password field</td>
<td>Upon the &quot;Change password&quot; operation, the entered password will be checked against your current password, both should be the same.</td>
</tr>
<tr>
<td>Set new password</td>
<td>- Enter your desired new password in the New Password field. Leave this empty if you do not want to use a password to login.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Enter the password entered in the previous step, again in the Confirm Password field. If you left the New Password field empty, leave this field empty too.</td>
<td>Upon the &quot;Change password&quot; operation, the entered passwords will be used as the new password.</td>
</tr>
<tr>
<td>Change password</td>
<td>- Set all fields in this screen</td>
<td>The change password screen will close and your password has now changed into the value you entered in New Password.</td>
</tr>
<tr>
<td>Cancel password change</td>
<td>- Click Cancel</td>
<td>The change password screen will close and your password has not been changed.</td>
</tr>
</tbody>
</table>

Possible errors

<table>
<thead>
<tr>
<th>Error message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td>The old password is incorrect</td>
<td>The password supplied in Old Password is not correct.</td>
</tr>
<tr>
<td>The supplied passwords do not match</td>
<td>The values entered in the New Password and Confirm Password fields are not the same.</td>
</tr>
</tbody>
</table>

Related screens
None
5.1.5 Open session screen

Functional description
This screen offers the functionality to open, delete, close or export an existing session. The top half of the screen displays a list of existing open sessions. The bottom half displays information for the selected session.
All exports are logged, this log can also be brought up from this screen.

![Open session screen](image)

Figure 5.5: Open session screen

Cautions and warnings
Once you delete a session, it cannot be recovered anymore.
Closed sessions cannot be opened again.

Operations

REFERENCES
<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display session information</td>
<td>- Select a session from the list</td>
<td>All available session information will be displayed in the lower half of the screen.</td>
</tr>
<tr>
<td>Open session</td>
<td>- Select a session from the list</td>
<td>The open session screen will close and the session screen (section 5.1.8) will appear, showing the session you just selected.</td>
</tr>
<tr>
<td>Delete session</td>
<td>- Select a session from the list</td>
<td>A messagebox asking for confirmation will appear. Upon confirmation the session will be deleted and removed from the session list.</td>
</tr>
<tr>
<td>Close session</td>
<td>- Select a session from the list</td>
<td>A messagebox asking for confirmation will appear. Upon confirmation the session will be closed and removed from the session list.</td>
</tr>
<tr>
<td>Export session to Excel file</td>
<td>- Select a session from the list</td>
<td>The session (and samples it contains) will be exported to a Microsoft Excel file.</td>
</tr>
</tbody>
</table>
| Show export log          | - Click Export and select Show Export Log                            | - A standard Windows save file dialog will appear. Browse for the location where you want to save the file. 
- Enter the desired filename in the Filename field 
- Click Save |

Possible errors
None

Related screens
Reference topic  
Session screen  5.1.8

5.1.6 Show Log screen

Functional description
This screen offers the possibility to view and clear the log file.

![Figure 5.6: Show Log screen](image)

Cautions and warnings
None
### 5.1.7 Create new session screen

#### Functional description
This screen offers the functionality to create a new session. It asks for some basic information and creates a session using this information.

![Create New Session](image)

**Figure 5.7: Create new session screen**

#### Cautions and warnings
The information filled in in this screen cannot be changed after pressing *Ok*.

#### Operations
Soft w a re User Manual bICEPS

Operation          Steps                                      Result
-------------------------------------------------------------
Set new session name - Enter a name for the session in the Session Name field

Result Upon the "Create new session" operation, the entered name will be used as name for the session.

Set project name - (Optional) Enter the name of the project this session belongs to in the Project Name field

Result Upon the "Create new session" operation, the entered project name will be saved with the session.

Set project number - (Optional) Enter the number of the project this session belongs to in the Project Number field

Result Upon the "Create new session" operation, the entered project number will be saved with the session.

Set attribute list - Choose an attribute list from the Attribute list dropdownlist

Result Upon the "Create new session" operation, the chosen attribute list will be used for the session.

Create new session - Set the session name and attribute list (project name and number are optional)
- Click Ok

Result The new session screen will close and the session screen (section 5.1.8) will appear, containing your newly created session.

Cancel creation - Click Cancel

Result The new session screen will close and the create new session screen will close and no new session is created.

Possible errors

Error message Cause
Please enter a session name You did not enter a session name in the Session Name field.
Please choose an attribute list You did not choose an attribute list in the Attribute list dropdownlist.

Related screens

Reference topic Section
Session screen 5.1.8

5.1.8 Session screen

Functional description
This screen offers an overview of all information for a session and all samples for this session. It also serves as a starting point for starting new sample evaluations and manipulating the samples in the session.

![Figure 5.8: Session screen](image-url)
### Cautions and warnings

Once you delete a sample, there is no way to recover it.

<table>
<thead>
<tr>
<th>Operations</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change session description</td>
<td>- Enter the desired description in the Description textbox</td>
<td>The description will be automatically saved</td>
</tr>
</tbody>
</table>
| Start new sample evaluation | - Click *New Sample*  
- Enter a new name for the sample | The sample evaluation screen (section 5.1.9) will appear. |
| Delete sample | - Select the sample you want to delete in the list on the right  
- Click *Delete Sample* | A message box asking for confirmation will appear. Upon confirmation the sample will be deleted and removed from the list of samples. |
| Copy sample | - Select the sample you want to copy from the list on the right  
- Click *Copy Sample*  
- Enter a name for the copy  
- Click *Ok* | The selected sample is copied and added to the list under the name you gave in step three. |
| Open sample for evaluation | - Select the sample you want to open from the list on the right  
- Click *Open Sample* or double click on the sample in the list | The sample evaluation screen (section 5.1.9) will appear, showing the evaluation for the selected sample. |
| Show sample overview | - Click *Sample Overview* | The sample overview screen (section 5.1.10) will appear, showing an overview of the samples for this session. |

### Possible errors

<table>
<thead>
<tr>
<th>Error message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>A sample with this name already exists</em></td>
<td>The name you entered upon creating or copying a sample already exists in this session.</td>
</tr>
</tbody>
</table>

### Related screens

<table>
<thead>
<tr>
<th>Reference topic</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sample evaluation screen</td>
<td>5.1.9</td>
</tr>
<tr>
<td>Sample overview screen</td>
<td>5.1.10</td>
</tr>
</tbody>
</table>

### 5.1.9 Sample evaluation screen

#### Functional description

This screen contains all necessary functions to evaluate a sample. Furthermore the quality mark, remarks and physical attributes of a sample can be entered in this screen.

The screen consists of a maximum of 6 tabs and 3 buttons. The four leftmost tabs are used for assigning scores to each attribute. The fifth tab is used for the quality mark and remarks, while the sixth tab is used for assigning values to the list of physical attributes.

The buttons are used to control the course of the evaluation, they can be used to save and cancel the evaluation and to mark a sample as "bad".

#### Cautions and warnings

We assume the chosen attribute list has attributes for all tabs. If a tab has no attributes, it will not be visible.

When canceling an evaluation, all entered information will be discarded, there is no way to retrieve this information once an evaluation is canceled by the user.
Figure 5.9: Sample evaluation screen
<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evaluate an attribute</td>
<td>- Select one of the four leftmost tabs</td>
<td>The evaluation for this attribute is saved.</td>
</tr>
<tr>
<td></td>
<td>- Drag the slider next to an attribute name to the desired position, the textbox on the right will display the current value</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- (Alternative to previous step) Enter a number in the range [0,100] in the textbox on the right, the slider will automatically move to this position</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Select any other control in the screen</td>
<td></td>
</tr>
<tr>
<td>Enter quality mark</td>
<td>- Select the tab labeled Remarks</td>
<td>The quality mark is saved.</td>
</tr>
<tr>
<td></td>
<td>- Enter a value in the range [0..10] in the Quality Mark field. You can use a precision of 1 hundredth, use a comma or dot as decimal separator</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Select any other control in the screen</td>
<td></td>
</tr>
<tr>
<td>Enter remark</td>
<td>- Select the tab labeled Remarks</td>
<td>The remark is saved.</td>
</tr>
<tr>
<td></td>
<td>- Enter a remark in the Remarks textbox</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Select any other control in the screen</td>
<td></td>
</tr>
<tr>
<td>Enter physical attribute</td>
<td>- Select the tab labeled Physics</td>
<td>The value for the physical attribute is saved.</td>
</tr>
<tr>
<td></td>
<td>- Enter a value in the textbox next to the name of a physical attribute</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Select any other control in the screen</td>
<td></td>
</tr>
<tr>
<td>Mark sample as &quot;bad&quot;</td>
<td>- Click Bad Sample</td>
<td>All attributes that were not evaluated yet will be given a score of 0, the sample will receive a quality mark of 0.0 and the Remarks textbox will contain the text &quot;Bad Sample&quot;. The tab labeled Remarks will be selected.</td>
</tr>
<tr>
<td>Save evaluation</td>
<td>- Click Save Evaluation</td>
<td>The sample evaluation screen will close and the sample evaluation is saved.</td>
</tr>
<tr>
<td>Cancel evaluation</td>
<td>- Click Cancel Evaluation or close the sample evaluation screen by clicking the cross in the right upper corner</td>
<td>The sample evaluation screen will close and the sample and its evaluation is discarded.</td>
</tr>
</tbody>
</table>

### Possible errors

<table>
<thead>
<tr>
<th>Error message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td>Please enter a number between 0 and 10</td>
<td>You entered a value outside the range [0..10] or a non-number in the Quality Mark field.</td>
</tr>
</tbody>
</table>

### Related screens

None

### 5.1.10 Sample overview screen

#### Functional description

This screen contains an overview of all samples in a session. The session information box at the top contains a summary of the available information for the session. The table on the bottom part of the screen contains an overview of all samples (each sample has its own column) and for each sample their scores for each attribute, the quality mark and scores for physical attributes. It is possible to change the displayed attribute values in this screen.
Furthermore a graph of all the sample can be generated and the overview can be printed.

![Sample Overview Screen](image)

Figure 5.10: Sample overview screen

**Cautions and warnings**
If this screen was opened from the closed sessions overview screen (section 5.1.20), only the physical attribute scores can be changed.

<table>
<thead>
<tr>
<th>Operations</th>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print sample</td>
<td>Print sample</td>
<td>- Click Print</td>
<td>The sample overview will be printed.</td>
</tr>
<tr>
<td></td>
<td>overview</td>
<td>- A standard Windows print dialog will appear, select the desired options and click Print</td>
<td></td>
</tr>
<tr>
<td>Show graph</td>
<td>Show graph for all</td>
<td>- Click Show Graph</td>
<td>The graph screen (section 5.1.18) will appear, containing the samples shown in the sample overview screen.</td>
</tr>
<tr>
<td></td>
<td>samples</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Change attributes</td>
<td>score</td>
<td>- Double click on a value in a row with an attribute name</td>
<td>The new value is saved.</td>
</tr>
<tr>
<td></td>
<td>(normal or</td>
<td>- Enter a value in the range [0..100]</td>
<td></td>
</tr>
<tr>
<td></td>
<td>physical)</td>
<td>- Select any other field in the table</td>
<td></td>
</tr>
</tbody>
</table>

**Possible errors**

<table>
<thead>
<tr>
<th>Error message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is not a valid score</td>
<td>You entered a value outside of the range [0..100] in an attribute value field.</td>
</tr>
<tr>
<td>This is not a valid quality mark</td>
<td>You entered a value outside of the range [0..10] in a quality mark field.</td>
</tr>
</tbody>
</table>

**Related screens**

<table>
<thead>
<tr>
<th>Reference topic</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graph screen</td>
<td>5.1.18</td>
</tr>
</tbody>
</table>
5.1.11 Custom attribute list screen

**Functional description**
This screen contains all functionality to compose a custom attribute list out of protected and custom attributes. The screen is used for both creating new custom attribute lists as well as for changing existing lists. It also contains a button to quickly add a new custom attribute.

![Figure 5.11: Custom attribute list screen](image)

**Cautions and warnings**
If you are changing an existing attribute list, upon saving, the old list version will be overwritten. From that point on it is no longer possible to use the old version of the list in newly created sessions.

**Operations**
**Operation** | **Steps** | **Result**
--- | --- | ---
Set attribute list name | - Enter the desired name in the *Attribute list Name* field | Upon saving this list, the entered value will be used as identifying name for the list.

Add protected attribute(s) to custom attribute list | - Select the tab labeled *Protected Attributes*  
  Alternative 1  
  - Select one or more (by holding ctrl and clicking) attributes you want to add to the list (you can pick multiple attributes in multiple categories)  
  - Click *Add*  
  Alternative 2  
  - Select one or more (by holding ctrl and clicking) attributes you want to add to the list (all attributes must be in the same category)  
  - Click and hold the left mouse button, now drag to the same category on the left side of the screen  
  - Release the left mouse button when inside the category list on the left | The selected attributes will have moved from the lists on the right to the lists on the left. Upon saving this custom attribute list, all attributes in the lists on the left will be in the custom attribute list.

Add custom attribute(s) to custom attribute list | - See "Add protected attribute to list!", make sure you select the tab labeled *Custom Attributes* instead of *Protected Attributes* | The selected attributes will have moved from the lists on the right to the lists on the left. Upon saving this custom attribute list, all attributes in the lists on the left will be in the custom attribute list.

Remove attribute(s) from custom attribute list | - Select one or more (by holding ctrl and clicking) attributes in the categories on the left  
  - Click *Remove* | The selected attributes will have moved from the lists on the left to the lists on the right. Upon saving this custom attribute list, all attributes in the lists on the left will be in the custom attribute list.

Open add new custom attribute screen | - Select the tab labeled *Custom Attributes*  
  - Click *Add New Custom Attribute* | The add new custom attribute screen (section 5.1.14) will appear.

Save custom attribute list | - Click *Save List* | The custom attribute list screen closes and the custom attribute list is saved. The attribute list can now be used in newly created sessions.

Cancel changes/creation | - Click *Cancel* or close the screen by clicking the cross in the right upper corner | A messagebox will ask for confirmation. Upon confirmation the custom attribute list screen will close and all changes will be discarded, if you were in the process of creating a new attribute list, no list is created.

Possible errors | Error message | Cause
--- | --- | ---
**Please enter a name for the list** | You did not enter a name for the attribute list in the *Attribute list Name* field.

**List cannot be empty** | You did not add any attributes to the attribute list.

REFERENCES 43
5.1.12 **Open custom attribute list screen**

**Functional description**

This screen contains the functionality to open or disable a custom attribute list. It consists of a list of available custom attribute lists and two buttons to open or disable a list. Disabling a list will make it unavailable for future use in new sessions, but keep it available for earlier created sessions.

![Custom Attribute Lists](image.png)

**Figure 5.12: Open custom attribute list screen**

**Cautions and warnings**

Once you disable a custom attribute list, there is no way to recover it.

<table>
<thead>
<tr>
<th>Operations</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open custom list</td>
<td>- Select the desired custom attribute list in the listbox&lt;br&gt;- Click <em>Change List</em></td>
<td>The custom attribute list screen (section 5.1.11) will appear.</td>
</tr>
<tr>
<td>Disable list</td>
<td>- Select the desired custom attribute list in the listbox&lt;br&gt;- Click <em>Disable List</em></td>
<td>A messagebox asking for confirmation will appear. Upon confirmation the selected attribute list will be disabled for future use.</td>
</tr>
</tbody>
</table>

**Possible errors**

None

**Related screens**

<table>
<thead>
<tr>
<th>Reference topic</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom attribute list screen</td>
<td>5.1.11</td>
</tr>
</tbody>
</table>
This screen contains all the functionality to maintain your custom attributes. These custom attributes can be used to form custom attribute lists. Custom attributes can be added or disabled in this screen. Disabling an attribute will make it unavailable for use in newly created attribute lists. It will, however, stay available for existing custom attribute lists.

![Manage Custom Attributes Screen](image)

**Figure 5.13: Manage custom attributes screen**

**Cautions and warnings**

Once you disable a custom attribute, there is no way to recover it. A disabled attribute that is still in a custom attribute list, and then is removed from that attribute list, cannot be added again because it is disabled.

<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open add new</td>
<td>- Click <em>Add Attribute</em></td>
<td>The add new custom attribute screen (section 5.1.14) will appear.</td>
</tr>
<tr>
<td>custom attribute</td>
<td></td>
<td></td>
</tr>
<tr>
<td>screen</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Disable attribute</td>
<td>- Select one or more (by holding ctrl and clicking) attributes you</td>
<td>A message box will appear, asking for confirmation. Upon confirmation,</td>
</tr>
<tr>
<td></td>
<td>wish to disable</td>
<td>the selected attributes will be disabled for future use and removed</td>
</tr>
<tr>
<td></td>
<td>- Click <em>Disable Attribute(s)</em></td>
<td>from the category lists.</td>
</tr>
</tbody>
</table>

**Possible errors**

None

REFERENCES 45
5.1.14 Add new custom attribute screen

Functional description
This screen offers the functionality to give a name and category for a new custom attribute. This screen can only be brought up from the manage custom attributes screen (5.1.13).

![Add New Custom Attribute dialog](image)

Figure 5.14: Add new custom attribute screen

Cautions and warnings
None

<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set attribute category</td>
<td>- Select the desired category from the <strong>Category</strong> dropdownlist</td>
<td>Upon the &quot;Add attribute&quot; operation, the selected category will be used as category for the new attribute.</td>
</tr>
<tr>
<td>Set attribute name</td>
<td>- Enter the desired name in the <strong>Attribute Name</strong> field</td>
<td>Upon the &quot;Add attribute&quot; operation, the entered name will be used as the name for the new attribute.</td>
</tr>
<tr>
<td>Add attribute</td>
<td>- Set the <strong>Category</strong> and <strong>Attribute Name</strong> fields - Click Ok</td>
<td>The add new custom attribute screen will close and the new attribute is added to the list of its category.</td>
</tr>
</tbody>
</table>

Possible errors

Error message: *There already exists an attribute with the same name*

Cause: You entered an attribute name in the **Attribute Name** field that already exists in the category selected in the **Category** dropdownlist.

Related screens

<table>
<thead>
<tr>
<th>Reference topic</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage custom attributes screen</td>
<td>5.1.13</td>
</tr>
</tbody>
</table>

5.1.15 PCA mapping options screen

Functional description
This screen offers the functionality to set the options for a PCA mapping which can then be generated. The list on the left displays a treeview of sessions and samples. The panel on the right shows session and sample information for the selected session/sample.

Cautions and warnings
None
Operations | Operation | Steps | Result
--- | --- | --- | ---
Select attribute list | - Select the desired attribute list from the *Attribute List* dropdown list. | The list on the left will display all open and finalized sessions, using the selected attribute list. | 
Select samples for PCA mapping | - Click on a checkbox in front of a session or sample in the list on the left | Clicking on a checkbox in front of a session will select all its samples. All checked samples will be included in the PCA mapping. | 
Display session information | - Click on a session in the list on the left | The panel on the right will show all relevant session information. | 
Display sample description | - Click on a sample in the list on the left | The panel on the right will show the sample's session information as well as the sample description. | 
Generate PCA mapping | - Click on the button labeled *Generate PCA Mapping* | The PCA mapping screen (section 5.1.16) will appear. Containing a PCA mapping of all selected samples. | 

Possible errors | Error message | Cause
--- | --- | ---
Please select at least 2 samples | You did not select at least 2 samples in the list on the left of the screen. | 

Related screens | Reference topic | Section
--- | --- | ---
PCA mapping screen | 5.1.16 | 

5.1.16 PCA mapping screen

Functional description
This screen shows a PCA mapping and offers various controls for influencing the way the mapping is displayed.

Cautions and warnings
None
Figure 5.16: PCA mapping options screen
<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pan mapping</td>
<td>- Click and hold the right mouse button in the mapping</td>
<td>Dragging the mouse in any direction will pan the mapping in that direction.</td>
</tr>
<tr>
<td>Hide/unhide displayed sample labels</td>
<td>- Click on the check box in front of a sample name</td>
<td>The selected sample will disappear from the PCA mapping.</td>
</tr>
<tr>
<td>Change mapping title</td>
<td>- Edit the value in the <em>Title</em> field</td>
<td>The value in the <em>Title</em> field will appear above the PCA mapping.</td>
</tr>
<tr>
<td>Change mapping subtitle</td>
<td>- Edit the value in the <em>Subtitle</em> field</td>
<td>The value in the <em>Subtitle</em> field will appear below the title, above the PCA mapping.</td>
</tr>
<tr>
<td>Invert x-axis</td>
<td>- Click on the checkbox in front of the label <em>Invert X-Axis</em></td>
<td>The attribute scores are inverted along the x-axis.</td>
</tr>
<tr>
<td>Invert y-axis</td>
<td>- Click on the checkbox in front of the label <em>Invert Y-Axis</em></td>
<td>The attribute scores are inverted along the y-axis.</td>
</tr>
<tr>
<td>Swap x- and y-axis</td>
<td>- Click on the checkbox in front of the label <em>Swap axes</em></td>
<td>The x- and y-axis are swapped.</td>
</tr>
<tr>
<td>Standardize attribute data</td>
<td>- Click on the checkbox in front of the label <em>Standardize data</em></td>
<td>All attribute data is standardized.</td>
</tr>
<tr>
<td>Enter zoom mode</td>
<td>- Click on the magnifying glass button</td>
<td>Zoom mode is enabled. The magnifying glass button is pressed down.</td>
</tr>
<tr>
<td>Zoom in/out in zoom mode</td>
<td>- Click and hold the left mouse button in the mapping</td>
<td>When moving the mouse to the left, you zoom in. Moving the mouse to the right will zoom out.</td>
</tr>
<tr>
<td>Exit zoom mode</td>
<td>- Click on the pressed down magnifying glass button</td>
<td>Zoom mode is disabled. The magnifying glass button is not pressed down.</td>
</tr>
<tr>
<td>Enter zoom x-axis mode</td>
<td>- Click on the x button</td>
<td>Zoom x-axis mode is enabled. The x button is pressed down.</td>
</tr>
<tr>
<td>Zoom in/out in zoom x-axis mode</td>
<td>- Click and hold the left mouse button in the mapping</td>
<td>When moving the mouse to the left, you zoom in along the x-axis. Moving the mouse to the right will zoom out along the x-axis.</td>
</tr>
<tr>
<td>Exit zoom x-axis mode</td>
<td>- Click on the pressed x button</td>
<td>Zoom x-axis mode is disabled. The x button is not pressed down.</td>
</tr>
<tr>
<td>Enter zoom y-axis mode</td>
<td>- Click on the y button</td>
<td>Zoom y-axis mode is enabled. The y button is pressed down.</td>
</tr>
</tbody>
</table>
### Zoom in/out in zoom y-axis mode
- Click and hold the left mouse button in the mapping
  
  When moving the mouse to the left, you zoom in along the y-axis. Moving the mouse to the right will zoom out along the y-axis.

### Exit zoom y-axis mode
- Click on the pressed y button
  
  Zoom y-axis mode is disabled. The y button is not pressed down.

### Enter attribute scale mode
- Click on the Att button
  
  Attribute scale mode is enabled. The Att button is pressed down.

### Scale in attribute scale mode
- Click and hold the left mouse button in the mapping
  
  When moving the mouse to the left, you scale all values up. Moving the mouse to the right will scale all values down.

### Exit attribute scale mode
- Click on the pressed Att button
  
  Attribute scale mode is disabled. The Att button is not pressed down.

### Recalculate mapping
- Click on the button labeled Recalculate
  
  The mapping will be recalculated using only the selected samples in the listbox in the top-left of the screen.

### Print mapping
- Click on the button labeled Print
  
  A standard Windows print dialog will appear. Here you can edit the printer settings and print the mapping.

### Save mapping to graphical file
- Click on the button labeled Save Picture
  
  A standard Windows file save dialog will appear. Here you can choose a location and filename for your picture and select the format to save in.

### Possible errors

<table>
<thead>
<tr>
<th>Error message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not enough data to produce PCA mapping</td>
<td>You did not select at least 2 samples in the list in the top-left of the screen.</td>
</tr>
</tbody>
</table>

### Related screens
None

---

5.1.17 Graph options screen

### Functional description
This screen offers the functionality to set the options for a sample data graph which can then be generated. The list on the left displays a treeview of sessions and samples. The panel on the right shows session and sample information for the selected session/sample.

### Cautions and warnings
None

### Operations

**Operation** | **Steps** | **Result**
--- | --- | ---
Show session’s samples | - Click the plus-sign in front of the desired session | The tree will expand and show the names of the samples for this session.

Hide session’s samples | - Click on the minus-sign in front of the desired session | The tree will collapse and hide the names of the samples for this session.

Generate graph | - Click on the checkbox of the sessions you would like to see a graph for, or, if it is expanded, click on one of its samples checkboxes - Click Generate Graph | The graph screen (section 5.1.18 will appear.

**Possible errors**

| Error message | Cause |
--- | --- |
Please select at least 1 sample | None of the samples in the list on the left were selected.

**Related screens**

| Reference topic | Section |
--- | --- |
Graph screen | 5.1.18 |

---

### 5.1.18 Graph screen

**Functional description**

This screen shows the graph based on the samples selected on the left of the screen. It also enables you to edit the graph and to print or save it.

**Cautions and warnings**

At most six samples can be selected to generate a graph.

If there where more than six samples selected in the graphoptions screen (section 5.1.17) the first six samples will be used to generate the graph.

**Operations**

---

REFERENCES 51
### Operation | Steps | Result
--- | --- | ---
Deselect a sample showed in the graph | - Click the checkbox in front of the sample you want to deselect | The sample will be removed from the graph on the right side of the screen.
Select a sample to be shown in the graph | - Click the checkbox in front of the sample you want to show | The sample will be added to the graph on the right side of the screen.
Change the color of a line in the graph | - Select a color from any of the six drop-down lists. | The line color will change to the selected color.
Change the line thickness | - Set the Line Thickness field. | The graph line thickness will be changed.
Print the graph | - Click the Print button
- A standard Windows print dialog will appear, select the desired options and click Print | The graph will be printed.
Save the picture | - Click the Save Picture button
- A standard Windows save dialog will appear, select the desired options and click Save to save the data to a file | The graph will be saved.

### Possible errors
None

### Related screens
None
5.1.19 Database operations screen

Functional description
This screen consists of only buttons that will open up the closed sessions overview screen (section 5.1.20) with a list of matching sessions.

![Database Operations Screen](image)

Figure 5.19: Database operations screen

Cautions and warnings
None

<table>
<thead>
<tr>
<th>Operations</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show all closed sessions</td>
<td>- Click Show Closed Sessions</td>
<td>The closed sessions overview screen (section 5.1.20) will appear with a list of all closed sessions.</td>
</tr>
<tr>
<td>Show all closed sessions with a certain project name</td>
<td>- Click Show Closed Sessions For Project - Enter the desired project name in the message box - Click Ok</td>
<td>The closed sessions overview screen (section 5.1.20) will appear with a list of all closed sessions with a project name value containing a part of or equal to the one just entered.</td>
</tr>
<tr>
<td>Show all closed sessions with a certain name</td>
<td>- Click Show Closed Sessions With Name - Enter the desired name in the message box - Click Ok</td>
<td>The closed sessions overview screen (section 5.1.20) will appear with a list of all closed sessions with a name that contains the value just entered (i.e. the entered value is a subset of the session name).</td>
</tr>
<tr>
<td>Show all closed sessions with a certain start date</td>
<td>- Click Show Closed Sessions With Start date - Enter the desired start date in the message box (dd-mm-yyyy format) - Click Ok</td>
<td>The closed sessions overview screen (section 5.1.20) will appear with a list of all closed sessions with a start date equal to the value just entered.</td>
</tr>
<tr>
<td>Show all closed sessions with a certain closing date</td>
<td>- Click Show Closed Sessions With Closing date - Enter the desired closing date in the message box (dd-mm-yyyy format) - Click Ok</td>
<td>The closed sessions overview screen (section 5.1.20) will appear with a list of all closed sessions with a closing date equal to the value just entered.</td>
</tr>
</tbody>
</table>

Possible errors

<table>
<thead>
<tr>
<th>Error message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value is not a date</td>
<td>The value you entered in the messagebox is not a date in the dd-mm-yyyy format.</td>
</tr>
</tbody>
</table>

Related screens

REFERENCES 53
5.1.20 Closed sessions overview screen

Functional description
This screen shows an overview of closed sessions matching certain criteria (see section 5.1.19). On the left is a treeview of all matching sessions and their samples. On the right is a box with information on the selected session.

![Screenshot of the Closed sessions overview screen]

Figure 5.20: Closed sessions overview screen

Cautions and warnings
None

Operations

<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show session's samples</td>
<td>- Click the plus-sign in front of the desired session</td>
<td>The tree will expand and show the names of the samples for this session.</td>
</tr>
<tr>
<td>Hide session's samples</td>
<td>- Click on the minus-sign in front of the desired session</td>
<td>The tree will collapse and hide the names of the samples for this session.</td>
</tr>
<tr>
<td>Show session info</td>
<td>- Click on the name of the session you would like to see info for, or, if it is expanded, click on one of its samples</td>
<td>The session information on the right will be updated and display information for the selected session.</td>
</tr>
</tbody>
</table>
| Open sample overview screen for a session | - Double click on the name of the session you would like to see info for, or, if it is expanded, double click on one of its samples  
- Or click the session you would like to see info for and click Show overview | The sample overview screen (section 5.1.10) will appear, containing the samples for that session. You can only change the physical attribute scores there (i.e. not the scores for normal attributes). |

Possible errors
None
5.1.21 Autosave

The autosave function is not a separate screen in ICEPS. It is a background function that constantly monitors the data the user enters in all screens. When ICEPS should crash, for whatever reason, and entered data has not yet been committed to the database, this function still has all the data from before the crash.

Whenever you start ICEPS after a crash, upon logging in, a messagebox will appear asking if you want you load the autosave. If you want to continue with the data you entered before the crash, click yes in this dialog. If you click No, all data that was not committed to the database before the crash will be lost (this includes open sample evaluations).

5.2 Administrator reference

This section serves as a reference for administrator users of the ICEPS system. Every screen in the system is documented here, along with all possible operations in the screen, examples of usage, possible errors and references to related screens.

5.2.1 Login screen

See section 5.1.1

5.2.2 ICEPS main administration screen

Functional description
This is the main administration screen of the ICEPS system. It mainly serves two purposes: firstly, to display all active screens the user has opened. Secondly, to act as an interface from which the user can open various screens that provide the main administrative functionality of ICEPS.

The top of the screen consists of a menu bar (displaying file, options, window etc.) and a toolbar with graphical buttons. All relevant screens can be opened from the menu. The toolbar acts as a shortcut for the menu and contains buttons for most screens in ICEPS.

The center of the screen is called the "workspace" and will contain all open screens.

The bottom of the screen consists of a statusbar that will display short help messages for every toolbar button.

Cautions and warnings
All screens that open up within the ICEPS main administration screen can be closed without closing ICEPS. If you close the ICEPS main administration screen, however, ICEPS will be closed too.

Operations
<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the new protected attribute list screen</td>
<td>- Click on the toolbar button labeled <strong>New Attribute list</strong> or select <strong>File -&gt; New Attribute list</strong> from the menu</td>
<td>The protected attribute list screen will appear (section 5.2.4).</td>
</tr>
<tr>
<td>Open the open protected attribute list screen</td>
<td>- Click on the toolbar button labeled <strong>Open Attribute list</strong> or select <strong>File -&gt; Open Attribute list</strong> from the menu</td>
<td>The open protected attribute list screen will appear (section 5.2.5).</td>
</tr>
<tr>
<td>Open the manage protected attributes screen</td>
<td>- Click on the toolbar button labeled <strong>Manage Attributes</strong> or select <strong>File -&gt; Manage Attributes</strong> from the menu</td>
<td>The manage protected attributes screen will appear (section 5.2.6).</td>
</tr>
<tr>
<td>Open the manage physics attribute list screen</td>
<td>- Click on the toolbar button labeled <strong>Manage Physics Attribute list</strong> or select <strong>File -&gt; Manage Physics Attribute list</strong> from the menu</td>
<td>The manage physics attribute list screen will appear (section 5.2.7).</td>
</tr>
<tr>
<td>Export protected attributes and protected attribute lists</td>
<td>- Click on the toolbar button labeled <strong>Export</strong> and click on <strong>Attributes &amp; Lists</strong> or select <strong>Options -&gt; Export -&gt; Export Protected Attributes &amp; Lists</strong> from the menu - Now a standard Windows save file dialog will appear. Browse for the location where you want to save the file and enter a filename in the <strong>Filename</strong> field, then click <strong>Save</strong></td>
<td>A file with protected attributes and protected attribute lists will be created. This file can be imported in the ICEPS main screen (section 5.1.3).</td>
</tr>
<tr>
<td>Export physical attribute list</td>
<td>- Click on the toolbar button labeled <strong>Export</strong> and click on <strong>Physics</strong> or select <strong>Options -&gt; Export -&gt; Export List Of Physical Attributes</strong> from the menu</td>
<td>A file with protected attributes and protected attribute lists will be created. This file can be imported in the ICEPS main screen (section 5.1.3).</td>
</tr>
<tr>
<td>Open export log</td>
<td>- Click on the toolbar button labeled <strong>Export</strong> and click on <strong>Show Log</strong> or select <strong>Options -&gt; Shown Log</strong> from the menu</td>
<td>The export log will appear. This log shows a list exports along with export-date and -time.</td>
</tr>
</tbody>
</table>

Figure 5.21: ICEPS main administration screen
### Cascade open screens
- Select `Window -> Cascade` from the menu
The open screens will be cascaded.

### Close all open screens
- Select `Window -> Close All` from the menu
All open windows will be closed.

### Bring a certain screen to the foreground
- Select `Window` from the menu
- Now click on the name of the screen you want on the foreground
The selected screen is brought to the foreground.

### Possible errors
None

<table>
<thead>
<tr>
<th>Related screens</th>
<th>Reference topic</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change password screen</td>
<td>5.1.4</td>
<td></td>
</tr>
<tr>
<td>Protected attribute list screen</td>
<td>5.2.4</td>
<td></td>
</tr>
<tr>
<td>Open protected attribute list screen</td>
<td>5.2.4</td>
<td></td>
</tr>
<tr>
<td>Manage protected attributes screen</td>
<td>5.2.5</td>
<td></td>
</tr>
</tbody>
</table>

#### 5.2.3 Change password screen
See section 5.1.4

#### 5.2.4 Protected attribute list screen

**Functional description**
This screen contains all functionality to compose a protected attribute list out of protected attributes. The screen is used for both creating new protected attribute lists as well as for changing existing lists.

![Figure 5.22: Protected attribute list screen](image)

REFERENCES 57
### Cautions and warnings

If you are changing an existing attribute list, upon saving, the old list version will be overwritten.

<table>
<thead>
<tr>
<th>Operations</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Set attribute list name</strong></td>
<td>- Enter the desired name in the <em>Attribute list Name</em> field</td>
<td>Upon saving this list, the entered value will be used as identifying name for the list.</td>
</tr>
</tbody>
</table>
| **Add protected attribute(s) to protected attribute list** | Alternative 1 - Select one or more (by holding ctrl and clicking) attributes you want to add to the list (you can pick multiple attributes in multiple categories) - Click *Add*  
Alternative 2 - Select one or more (by holding ctrl and clicking) attributes you want to add to the list (all attributes must be in the same category) - Click and hold the left mouse button, now drag to the same category on the left side of the screen - Release the left mouse button when inside the category list on the left | The selected attributes will have moved from the lists on the right to the lists on the left. Upon saving this protected attribute list, all attributes in the lists on the left will be in the protected attribute list. |
| **Remove attribute(s) from protected attribute list** | - Select one or more (by holding ctrl and clicking) attributes in the categories on the left - Click *Remove* | The selected attributes will have moved from the lists on the left to the lists on the right. Upon saving this protected attribute list, all attributes in the lists on the left will be in the protected attribute list. |
| **Open add new protected attribute screen** | - Click *Add New Custom Attribute* | The add new protected attribute screen (section 5.2.8) will appear. |
| **Save protected attribute list** | - Click *Save List* | The protected attribute list screen closes and the protected attribute list is saved. |
| **Cancel changes/creation** | - Click *Cancel* or close the screen by clicking the cross in the right upper corner | A messagebox will ask for confirmation. Upon confirmation the protected attribute list screen will close and all changes will be discarded, if you were in the process of creating a new attribute list, no list is created. |

### Possible errors

<table>
<thead>
<tr>
<th>Error message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Please enter a name for the list</em></td>
<td>You did not enter a name for the attribute list in the <em>Attribute list Name</em> field.</td>
</tr>
<tr>
<td><em>List cannot be empty</em></td>
<td>You did not add any attributes to the attribute list.</td>
</tr>
</tbody>
</table>

### Related screens

<table>
<thead>
<tr>
<th>Reference topic</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Add new protected attribute list screen</strong></td>
<td>5.2.8</td>
</tr>
</tbody>
</table>
5.2.5 Open protected attribute list screen

**Functional description**
This screen contains the functionality to open or delete a protected attribute list. It consists of a list of available protected attribute lists and two buttons to open or delete a list.

![Image of protected attribute list screen]

**Figure 5.23: Open protected attribute list screen**

**Cautions and warnings**
Once you delete a protected attribute list, there is no way to recover it.

<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open protected attribute list</td>
<td>- Select the desired protected attribute list in the listbox</td>
<td>The protected attribute list screen (section 5.2.4) will appear.</td>
</tr>
<tr>
<td></td>
<td>- Click Change List</td>
<td></td>
</tr>
<tr>
<td>Delete protected attribute list</td>
<td>- Select the desired protected attribute list in the listbox</td>
<td>A messagebox asking for confirmation will appear. Upon confirmation the selected attribute list will be deleted.</td>
</tr>
<tr>
<td></td>
<td>- Click Delete List</td>
<td></td>
</tr>
</tbody>
</table>

**Possible errors**
None

**Related screens**

<table>
<thead>
<tr>
<th>Reference topic</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Protected attribute list screen</td>
<td>5.2.4</td>
</tr>
</tbody>
</table>

5.2.6 Manage protected attributes screen

**Functional description**
This screen contains all the functionality to maintain your protected attributes. These protected attributes can be used to form protected attribute lists. Protected attributes can be added or deleted in this screen. Deleting an attribute will make it unavailable for use in newly created attribute lists. It will, however, stay available for existing protected attribute lists.

**Cautions and warnings**
Once you delete a protected attribute, there is no way to recover it. A deleted attribute that is still in a protected attribute list, and then is removed from that attribute list, cannot be added again because it is deleted.

REFERENCES
### Operations

<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open add new protected attribute screen</td>
<td>- Click <em>Add Attribute</em></td>
<td>The add new protected attribute screen (section 5.2.8) will appear.</td>
</tr>
<tr>
<td>Delete attribute</td>
<td>- Select one or more (by holding ctrl and clicking) attributes you wish to delete - Click <em>Delete Attribute(s)</em></td>
<td>A message box will appear, asking for confirmation. Upon confirmation, the selected attributes will be deleted and removed from the category lists.</td>
</tr>
</tbody>
</table>

**Possible errors**

None

**Related screens**

<table>
<thead>
<tr>
<th>Reference topic</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add new protected attribute screen</td>
<td>5.2.8</td>
</tr>
</tbody>
</table>

### 5.2.7 Manage physics attribute list screen

**Functional description**

This screen contains all functionality to manage the list of physical attributes on which a sample should be evaluated. It contains a list of physical attributes and two buttons to add and delete attributes.

**Cautions and warnings**

Once you delete a physical attribute there is no way to recover it.

**Operations**
Figure 5.25: Manage physics attribute list screen

<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add attribute</td>
<td>- Click Add Attributes</td>
<td>The entered name is added to the list of physical attributes and is added to the list in the screen.</td>
</tr>
<tr>
<td></td>
<td>- Enter a name for the attribute in the message box</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Click Ok</td>
<td></td>
</tr>
<tr>
<td>Delete attribute</td>
<td>- Select the desired attribute</td>
<td>A message box asking for confirmation will appear. Upon confirmation, the selected attribute will be deleted and remove from the list in the screen.</td>
</tr>
<tr>
<td></td>
<td>- Click Delete Attribute</td>
<td></td>
</tr>
</tbody>
</table>

Possible errors

<table>
<thead>
<tr>
<th>Error message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td>There already exists a physics attribute with the same name</td>
<td>You entered an attribute name in the field in the message-box that already exists list of physical attributes.</td>
</tr>
</tbody>
</table>

Related screens

None

5.2.8 Add new protected attribute screen

Functional description
This screen offers the functionality to give a name and category for a new protected attribute. This screen can only be brought up from the manage protected attributes screen [5.2.6].

Operations
Figure 5.26: Add new protected attribute screen

<table>
<thead>
<tr>
<th>Operation</th>
<th>Steps</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set attribute</td>
<td>- Select the desired category from the Category</td>
<td>Upon the &quot;Add attribute&quot; operation, the selected category will be used as</td>
</tr>
<tr>
<td>category</td>
<td>dropdownlist</td>
<td>category for the new attribute.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Set attribute</td>
<td>- Enter the desired name in the Attribute Name</td>
<td>Upon the &quot;Add attribute&quot; operation, the entered name will be used as the</td>
</tr>
<tr>
<td>name</td>
<td>field</td>
<td>name for the new attribute.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add attribute</td>
<td>- Set the Category and Attribute Name fields</td>
<td>The add new protected attribute screen will close and the new attribute</td>
</tr>
<tr>
<td></td>
<td>- Click Ok</td>
<td>is added to the list of its category.</td>
</tr>
</tbody>
</table>

Possible errors

<table>
<thead>
<tr>
<th>Error message</th>
<th>Cause</th>
</tr>
</thead>
<tbody>
<tr>
<td>There already exist an attribute with the same</td>
<td>You entered an attribute name in the Attribute Name field that already exists in the category selected in the Category</td>
</tr>
<tr>
<td>name and category</td>
<td>dropdownlist.</td>
</tr>
</tbody>
</table>

Related screens

<table>
<thead>
<tr>
<th>Reference topic</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage protected attributes screen</td>
<td>5.2.6</td>
</tr>
</tbody>
</table>
# Appendix A

## Glossary

<table>
<thead>
<tr>
<th>Term</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>User</td>
<td>Any user of the ICEPS system</td>
</tr>
<tr>
<td>End-User</td>
<td>The normal users of the ICEPS system, usually they will be Sara Lee/DE coffee experts</td>
</tr>
<tr>
<td>Administrator</td>
<td>The administrator users of the ICEPS system</td>
</tr>
<tr>
<td>Sample</td>
<td>A coffee sample</td>
</tr>
<tr>
<td>Session</td>
<td>A group of samples, grouped together because they belong to the same project, are evaluated shortly after one another and are evaluated with the same attribute list</td>
</tr>
<tr>
<td>Attribute</td>
<td>A property of a coffee sample, belonging to a category</td>
</tr>
<tr>
<td>Category</td>
<td>This can be: appearance, smell, taste or aftertaste</td>
</tr>
<tr>
<td>Attribute list</td>
<td>A list of attributes on which a sample can be evaluated</td>
</tr>
<tr>
<td>Attribute score</td>
<td>The value assigned by an end-user to an attribute</td>
</tr>
<tr>
<td>Physical attribute</td>
<td>A property of a coffee sample, specifically dealing with physical properties like viscosity or temperature</td>
</tr>
<tr>
<td>Microsoft Excel</td>
<td>A spreadsheet software package by Microsoft</td>
</tr>
</tbody>
</table>
Index

attribute
  custom, 18
  add, 45
  create, 46
  disable, 45
  manage, 31
  evaluate, 10–11
  physics, 26
  manage, 56, 60
  protected, 22–23
    add, 59
    create, 61
    delete, 59
    manage, 56

attribute list
  custom, 19, 20
  create, 31, 42
  disable, 44
  edit, 42
  open, 31, 44
  protected, 24–25
    create, 56, 57
    delete, 59
    edit, 57
    open, 56, 59
  autosave, 55

database, 31, 53

export
  data, 27, 56
  log, 35, 56
  microsoft excel, 13, 35

graph, 13, 31, 50, 51

import, 17, 42
installation, 3

log, 35
login, 7, 21, 28

main screen, 30
  administrator, 55

password
  change, 8, 32, 33, 56

pcas, 15, 31, 46, 47

register, 6, 29

sample, 37

evaluation, 35
  overview, 11, 40
session, 37
  close, 13, 34
  closed
    overview, 16, 17, 54
    create, 34, 31, 36
    delete, 13, 34
    export, 13, 34
    open, 34, 31, 34
    sample overview, 40
uninstallation, 5

visualization
  graph, 13, 31, 50, 51
  pca mapping, 15, 31, 46, 47